Cannot edit a feature

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
9/20/2010 6:13:52 PM
Gravatar
Total Posts 249

Cannot edit a feature

After updating to latest version, everything was ok, i edited some features.

Then, I transformed my site in a multi-site installation.

From then, if I click on feature setting, i get this:

2010-09-21 00:54:00,439 ERROR mojoPortal.Web.Global - 127.0.0.1-it-IT - /Admin/ModuleSettings.aspx?mid=135&pageid=7
System.IO.IOException: Unable to resolve the file name..

in System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
in System.IO.FileSystemEnumerableIterator`1.CommonInit()
in System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler)
in System.IO.DirectoryInfo.InternalGetFiles(String searchPattern, SearchOption searchOption)
in mojoPortal.Web.AdminUI.ModuleSettingsPage.PopulateLabels()
in mojoPortal.Web.AdminUI.ModuleSettingsPage.Page_Load(Object sender, EventArgs e)
in mojoPortal.Web.mojoBasePage.OnLoad(EventArgs e)
in System.Web.UI.Control.LoadRecursive()
in System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 

What i did wrong?

9/20/2010 6:37:24 PM
Gravatar
Total Posts 18439

Re: Cannot edit a feature

I don't know, I would try recycle the app pool.

I'm done for today but I'll try to help tomorrow, maybe set it back as it was if the problem is holding you up.

What kind of multi site did you setup?

Best,

Joe

9/20/2010 6:54:16 PM
Gravatar
Total Posts 249

Re: Cannot edit a feature

Hi, a scandisk fixed the problem

Sunday night i had a bsod for an unknown reason (maybe a faulty ram module? the morning a disk in the softraid array was rebuilding itself - strange), and i did not notice that /Data/SiteImages/FeatureIcons was damaged and not accessible

You must sign in to post in the forums. This thread is closed to new posts.