Hosting Requirements

mojoPortal content management system requires ASP.NET 3.5 SP1 or higher and a database. If possible use .NET 4.5 hosting for best results. There are numerous hosting providers which offer ASP.NET hosting and mojoportal should work fine at most of them. We recommend a few hosting providers on our hosting partners page that we know to be very reliable for hosting mojoPortal. We think Arvixe is one of the best hosting providers around but you are free to shop around.

Although mojoPortal can work with 5 different databases, MSSQL/SQLExpress/SQL-CE/SQL-Azure, MySql, PostgreSQl, Firebird Sql, and SQLite, you will most commonly find that hosting providers offer MSSQL/SQLExpress and a few offer MySql in addition. I don't know of any hosting providers offering the other databases so those could likely only be used on your own servers.

In general, if you are a non-technical person and you want to use mojoPortal, I recommened you go with hosting on a Windows server using MSSQL/SQLExpress, and if you don't already have hosting go with one of our recommended hosts and you should have no problems.

If you are planning to host mojoPortal on your own server(s) instead of using a third party web host, you may want to read the Web Site Configuration documentation.

  • ASP.NET 3.5 SP1 or ASP.NET 4.0/4.5
  • IIS 6 or higher
  • Database
    • MSSQL 2005\2008\Azure
    • MSSQL-CE 4
    • MySQL
    • PostgreSQL
    • Firebird SQL
    • SQLite
Rate this Content 25 Votes