Feed Manager: Takes Site Down

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
7/29/2010 2:14:10 PM
Gravatar
Total Posts 2188

Feed Manager: Takes Site Down

Hi Joe,

I had a site down today because of a bad RSS feed. The site was using two instances of the Feed Manager. One consumed an external RSS Feed on a single page named "Devotionals." The second Feed Manager was on the home page and consumed local feeds including the aggregated feed from the "Devotionals" page. This configuration has been working for at least a year but today it got corrupted. If you view the external feed url (http://www.crosswalk.com/devotionals/rss/) an error is posted stating:

End tag 'description' does not match the start tag 'p'. Error processing resource 'http://www.crosswalk.com/devotionals/rss...

	<link>http://www.crosswalk.com/devotions/11531657/</link><description><p>Do you know what quie...

I know this error isn't a mojoPortal problem except that the Feed Manager tried consuming the feed and took the site down in the process. The following is from the System Log:

2010-07-29 13:47:06,214 ERROR mojoPortal.Web.AppKeepAliveTask - System.Net.WebException: The operation has timed out
   at System.Net.HttpWebRequest.GetResponse()
   at mojoPortal.Web.AppKeepAliveTask.DoKeepAlive()

2010-07-29 13:47:06,525 ERROR mojoPortal.Web.FeedUI.FeedCache - There was a problem trying to read the feed for url http://acckc.org/aggregator73rss.aspx.  Ignoring.
System.Net.WebException: The operation has timed out
   at System.Net.HttpWebRequest.GetResponse()
   at Argotic.Common.SyndicationEncodingUtility.CreateWebResponse(Uri source, ICredentials credentials, IWebProxy proxy)
   at Argotic.Common.SyndicationEncodingUtility.CreateSafeNavigator(Uri source, ICredentials credentials, IWebProxy proxy, Encoding encoding)
   at Argotic.Syndication.GenericSyndicationFeed.Load(Uri source, ICredentials credentials, IWebProxy proxy, SyndicationResourceLoadSettings settings)
   at Argotic.Syndication.GenericSyndicationFeed.Create(Uri source)
   at mojoPortal.Web.FeedUI.FeedCache.GetRssFeedEntries(Int32 moduleId, Guid moduleGuid, Int32 entryCacheTimeout, Int32 maxDaysOld, Int32 maxEntriesPerFeed, Boolean enableSelectivePublishing)

2010-07-29 13:47:06,889 ERROR mojoPortal.Web.FeedUI.FeedCache - There was a problem trying to read the feed for url http://www.crosswalk.com/devotionals/rss/.  Ignoring.
System.Xml.XmlException: The 'p' start tag on line 35 does not match the end tag of 'description'. Line 35, position 329.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ThrowTagMismatch(NodeData startTag)
   at System.Xml.XmlTextReaderImpl.ParseEndElement()
   at System.Xml.XmlTextReaderImpl.ParseElementContent()
   at System.Xml.XPath.XPathDocument.LoadFromReader(XmlReader reader, XmlSpace space)
   at System.Xml.XPath.XPathDocument..ctor(TextReader textReader)
   at Argotic.Common.SyndicationEncodingUtility.CreateSafeNavigator(String xml)
   at Argotic.Common.SyndicationEncodingUtility.CreateSafeNavigator(Stream stream, Encoding encoding)
   at Argotic.Common.SyndicationEncodingUtility.CreateSafeNavigator(Stream stream)
   at Argotic.Common.SyndicationEncodingUtility.CreateSafeNavigator(Uri source, ICredentials credentials, IWebProxy proxy, Encoding encoding)
   at Argotic.Syndication.GenericSyndicationFeed.Load(Uri source, ICredentials credentials, IWebProxy proxy, SyndicationResourceLoadSettings settings)
   at Argotic.Syndication.GenericSyndicationFeed.Create(Uri source)
   at mojoPortal.Web.FeedUI.FeedCache.GetRssFeedEntries(Int32 moduleId, Guid moduleGuid, Int32 entryCacheTimeout, Int32 maxDaysOld, Int32 maxEntriesPerFeed, Boolean enableSelectivePublishing)

2010-07-29 13:47:06,898 ERROR mojoPortal.Web.Global - 64.57.210.112-en-US - /aggregator73rss.aspx
System.InvalidOperationException: Can't close RssWriter without first writing a channel.
   at Rss.RssWriter.Close()
   at Rss.RssFeed.write(RssWriter writer)
   at mojoPortal.Web.FeedUI.FeedAggregatePage.RenderRss(Int32 moduleId)
   at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
   at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

I tried resetting the app pool, clearing the TaskQueue (manually at the mp_TaskQueue table as the site wouldn't respond), deleting the dependency files in \data\sites\1\systemfiles, and doing various combinations of all three but the site did not come back up until after I removed the faulty RSS Feed URL from the mp_RssFeeds table. After doing this, I reset the AppPool and the site came right up (well, after the usual JIT delay).

I can send you more logs if you like. If I left something out, let me know and I will try to clarify the problem.

Thanks,
Joe D.

7/30/2010 10:15:35 AM
Gravatar
Total Posts 18439

Re: Feed Manager: Takes Site Down

Hi Joe,

I'm able to produce this problem using the bad feed. It seems to be a bug in the outbound aggregate feed if there is a problem consuming a feed. I will look into this today.

Best,

Joe

You must sign in to post in the forums. This thread is closed to new posts.