Google site map problem

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
10/15/2009 4:23:38 AM
Gravatar
Total Posts 69

Google site map problem

Hi

We have a site where some of the links in the main menu point to a different domain. The problem is that when the sitemap is generated (SiteMap.ashx) Google's Webmaster Tools rejects it because of the external links with the message 'This url is not allowed for a Sitemap at this location.'

Any suggestions as to how to fix this?

10/15/2009 8:15:21 AM
Gravatar
Total Posts 18439

Re: Google site map problem

Go to Administration > Add/Edit Pages, find it in the list and click the gears to get to page settings. Then uncheck the box "Include In Site Map"

Hope it helps,

Joe

10/15/2009 10:56:56 AM
Gravatar
Total Posts 69

Re: Google site map problem

ok, done that but 'Include In Site map' isn't one of the options available

10/15/2009 12:15:39 PM
Gravatar
Total Posts 2169

Re: Google site map problem

What version of mojoPortal are you running? You can check this by going to Administration > System Information.

-Joe D.

10/16/2009 2:46:36 AM
Gravatar
Total Posts 69

Re: Google site map problem

2.2.7.3

10/16/2009 6:31:08 AM
Gravatar
Total Posts 18439

Re: Google site map problem

Thats a very old version, it does not include the "Show In Site Map" option. Upgrading would be desireable but a couple things to be aware of before upgrading a version that old.

1. The latest version of mojoPortal requires .NET 3.5 SP1 whereas your current version only required 2.0.

3. There have been changes to our skinning system that will require changes to your skin.

Note also that unchecking the "Show In SiteMap" (in the current 2.3.1.9 version) also would remove the link from the user site map page. I'm going to add a separate setting for the next version to differentiate between the search engine site map and the user site map.

Hope it helps,

Joe

You must sign in to post in the forums. This thread is closed to new posts.