E-mail issue with Forms Wizard Pro

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
8/23/2009 9:42:12 PM
Gravatar
Total Posts 1

E-mail issue with Forms Wizard Pro

Installed the Forms Wizard Pro

  and the e-mail address asigned to the form is not sending email when new entry is created.  Regular forms work fine.

8/24/2009 8:42:47 AM
Gravatar
Total Posts 2169

Re: E-mail issue with Forms Wizard Pro

Does the email address you assigned to the form actually exist on your email server?

For instance, I have my email servers configured to not allow a message to be sent from an address that doesn't exist.

If the address does exist, check the mojo log. You can find the log by going to the Administration Menu and then clicking on the "System Log" link.

8/24/2009 3:49:01 PM
Gravatar
Total Posts 18439

Re: E-mail issue with Forms Wizard Pro

Note that the email assigned on the form is not the "sender" of the emails but the recipient of form post notifications. Make sure that in Site Settings you have specified the default email from address the same as what you have in config settings for smtp. If the contact form works the Form Wizard should also work. It does work on the demo site and my own site and my local machine.

Hope it helps,

Joe

10/18/2012 1:44:00 PM
Gravatar
Total Posts 55

Re: E-mail issue with Forms Wizard Pro

I was wondering why email notifications aren't going to a 2nd email address that I put in the notification field for this form: http://www.parentjobnet.org/general-registration-form.aspx.

This is my log. pjnproject@gmail.com does exist and I did a test. Nothing came to that address. 

at mojoPortal.Net.Email.Send(SmtpSettings smtpSettings, MailMessage message)
2012-10-18 10:18:01,594 ERROR 108.46.12.123 - en-US - /general-registration-form.aspx - mojoPortal.Net.Email - all retries failed sending email to pjnproject@gmail.com from info@parentjobnet.org, message was: <html><head><title>PJN Registration Form Submission Recieved</title><head><body>Received From Site User: Tony Yao<br />From Url: http://www.parentjobnet.org/general-registration-form.aspx<br />From IP Address: 108.46.12.123<br /><br />Date<br />10/18/2012<br /><br />Salutation<br />Mr.<br /><br />First Name<br />Tony<br /><br />Last Name<br />Yao<br /><br />Email Address<br />tonyyao82@gmail.com<br /><br />Year of Birth (4 digits)<br />1982<br /><br />Last 4 Digits of SSN #<br />3272<br /><br />Name of school(s) children attend<br />P.S. 279<br /><br />Public School<br />Yes<br /><br />Private School<br />No<br /><br />Number of children in age groups: 0-5<br />1<br /><br />Number of children in age groups: 6-18<br />0<br /><br />Number of children in age groups: 19+<br />0<br /><br />Home Phone <br />(718) 763-1608<br /><br />Cell Phone<br />917-374-8987<br /><br />Street Address<br />1642 East 95th Street<br /><br />City<br />Brooklyn<br /><br />State<br />NY<br /><br />Zip<br />11236<br /><br />Referred By<br />PJN<br /><br />Marital Status<br />Married<br /><br />Single female head of household<br />No<br /><br />Sex<br />Male<br /><br />Preferred Method of Contact<br />By Email<br /><br />Primary Language<br />Chinese<br /><br />Best Time to Reach You<br />Daytime (9:00am - 5:00pm)<br /><br />Are you homeless? <br />No<br /><br />Do you rent your own apartment?<br />No<br /><br />Are you a resident of public housing? <br />No<br /><br />Do you own your house? <br />Yes<br /><br />How many adults living in the household?<br />2<br /><br />How many children living in the household?<br />1<br /><br />Are you the head of your household? <br />No<br /><br />Employed?<br />Yes<br /><br />Seeking employment?<br />No<br /><br />Collecting unemployment?<br />No<br /><br />Collecting public assistance?<br />No<br /><br />Collecting SSI?<br />No<br /><br />Collecting food stamps?<br />No<br /><br />If Employed, What is Your Annual Salary Range?<br />$30,000 to $40,000 per year<br /><br />Salary range of your spouse:<br />$20,000 to $30,000 per year<br /><br />Ethnicity:<br />Asian<br /><br />Education:Please select the highest qualification<br />Bachelor<br /><br />Would you like to learn more about our classes and workshops? (Check all that apply)<br />Career Support Workshop,Financial Literacy,Networking Event<br /><br />Would you like to meet with a career counselor?<br />No<br /><br />First time meeting with a career counselor?<br />No<br /><br />Do you have a computer at home?<br />Yes<br /><br />Do you have access to a computer?<br />Yes<br /><br />A form has been submitted, click the link below to view the submission:<br />http://www.parentjobnet.org/FormWizard/ViewSubmission.aspx?mid=103&pageid=120&rid=b0eb8e68-34cd-4141-9e02-78368212f30f<br /></body></html>
System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: SMTP authentication is required.

10/18/2012 2:56:35 PM
Gravatar
Total Posts 18439

Re: E-mail issue with Forms Wizard Pro

The code is doing what its supposed to do and trying to send the message, if it is failing it is failing for reasons beyond the control of mojoPortal.

"The server response was: SMTP authentication is required."

Sounds like something with your smtp server configuration but I'm not sure exactly what. The error sounds like possibly something with the from address needing to authenticate in order to send mail through your smtp server, but if its only happening with some messages I have no idea why unless different from addresses are used for some of them.

Best,

Joe

You must sign in to post in the forums. This thread is closed to new posts.