Store - add product problem

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
3/31/2009 9:34:19 AM
Gravatar
Total Posts 98

Store - add product problem

Hi ,

When I try to add new product on lastest release of mojoportal I get this error message :

2009-03-31 19:00:56,583 ERROR mojoPortal.Web.Global - 93.110.90.239-fa-IR - /WebStore/AdminProductEdit.aspx?pageid=6&mid=1
System.Web.HttpParseException: The tag contains duplicate 'CssClass' attributes. ---> System.Web.HttpException: The tag contains duplicate 'CssClass' attributes.
at System.Web.UI.TemplateParser.ProcessError(String message)
at System.Web.UI.TemplateParser.ProcessBeginTag(Match match, String inputText)
at System.Web.UI.TemplateParser.ParseStringInternal(String text, Encoding fileEncoding)
--- End of inner exception stack trace ---
at System.Web.UI.TemplateParser.ProcessException(Exception ex)
at System.Web.UI.TemplateParser.ParseStringInternal(String text, Encoding fileEncoding)
at System.Web.UI.TemplateParser.ParseString(String text, VirtualPath virtualPath, Encoding fileEncoding)
 

I try it on my local copy and also on demo.mojoportal with same result.

I find the problem in AdminProductEdit.aspx file:

<div class="settingrow">
<mp:SiteLabel ID="lblIsVisible" runat="server" CssClass="settinglabel" ConfigKey="ProductShowInListLabel"
ResourceFile="WebStoreResources" ForControl="chkShowInProductList" CssClass="forminput"/>
<asp:CheckBox ID="chkShowInProductList" runat="server"  />
</div>
<div class="settingrow">
<mp:SiteLabel ID="SiteLabel2" runat="server" CssClass="settinglabel" ConfigKey="ProductEnableRatingLabel"
ResourceFile="WebStoreResources" ForControl="chkEnableRating" CssClass="forminput" />
<asp:CheckBox ID="chkEnableRating" runat="server"  />
 

Lines 68 and 73 , the mp:SiteLabel  tags has 2 CssClass.

Thanks

Mehdi

3/31/2009 10:01:54 AM
Gravatar
Total Posts 18444

Re: Store - add product problem

Hi Mehdi,

Thanks for letting me know. I already knew about this bug but I thought it got fixed before the 2.2.9.6 release, but apparently not. I have fixed the demo site and I've created a .zip file with a patch to fix it. Just unzip this file and copy the two included files into your WebStore folder

WebStorePatch20090331.zip

Best,

Joe

You must sign in to post in the forums. This thread is closed to new posts.