Ready to upload production but can't find pageskin

A place for discussion about skinning and design. Before posting questions here you should review the documentation about creating skins.

This thread is closed to new posts. You must sign in to post in the forums.
1/15/2009 11:18:30 AM
Gravatar
Total Posts 30

Ready to upload production but can't find pageskin

Hi Joe,

Hope you're having a great new year. I am almost done with the first site and I can send you a reference to this website to add to your lists that runs mojo framework. I have this annoying error that when I upload to production server it gives me the "Pageskin" error for some reason, when I do a publish "Only files needed to run this application" I get this error, but when I use "All project files" then it works fine, according to my manager developer using the latter will not take advantage of the CS (compilation). Is this any true?

Anyway, I tried putting it inside "App_Theme" folder and jacked up the whole layout.

Appreciate any help.

regards,

-gil

1/15/2009 11:24:12 AM
Gravatar
Total Posts 18444

Re: Ready to upload production but can't find pageskin

The Visual Studio publish feature is not supported because it doesn't correctly handle our project structures. It only wants to deploy files that are included in the project, but many files are not from the web project they get copied there by post build events. So you can't rely on the VS publish feature to package the correct files.

You should use the free UnleashIt tool as described in the Deployment article.

Hope it helps,

Joe

1/15/2009 1:42:45 PM
Gravatar
Total Posts 30

Re: Ready to upload production but can't find pageskin

Joe, I tried it and it worked like magic, so easy to do, even the cavemen can do it ;-)  I highly recommend this tool 'Unleashed It' for all your deployments.

Thanks a lot, I'll send you the link soon as it is published.

-gil

You must sign in to post in the forums. This thread is closed to new posts.