File upload doesn't work in mono 1.1.8

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
6/26/2005 12:02:37 PM
Gravatar
Total Posts 18444

File upload doesn't work in mono 1.1.8

File Upload doesn't work in mono 1.1.8 for File Manager, Shared Files, and Gallery.

I believe this is another bug in mono since it works fine in 1.1.7, if I get time I will try to create a test case and submit a bug report
6/27/2005 12:21:23 PM
Gravatar
Total Posts 36

Re: File upload doesn't work in mono 1.1.8

This appears to work in SVN and 1.1.8.1
6/27/2005 2:34:08 PM
Gravatar
Total Posts 18444

Re: File upload doesn't work in mono 1.1.8

Yes Gonzalo fixed it in svn yesterday. Maybe it didn't impact the 1.1.8.x release, I've never tried the release version so it could have regressed after that but Gonzalo confirmed it yesterday then fixed it and all the other issues I was having. My demo site demo.mojoportal.com runs on the svn code and I haven't found any other problems so far.
7/11/2005 3:28:47 AM
Gravatar
Total Posts 49
Juliano Morais Barbosa

Re: File upload doesn't work in mono 1.1.8

When I use Upload file, the name of the file in linux get the total of path.
For example:
original file Location: C:\My Documents\Linux\Gentoo\install.doc

in Linux folder the name is C:\My Documents\Linux\Gentoo\install.doc
ls -lsa
C:\My Documents\Linux\Gentoo\install.doc

7/11/2005 1:47:18 PM
Gravatar
Total Posts 18444

Re: File upload doesn't work in mono 1.1.8

yes thats another bug in mono 1.1.8 but its fixed in the latest svn code of mono. You can easily rename it after upload as a workaround.
7/11/2005 4:26:30 PM
Gravatar
Total Posts 49
Juliano Morais Barbosa

Re: File upload doesn't work in mono 1.1.8

ok Joe,

But, my mono is 1.1.7 ok !!!
7/11/2005 4:52:01 PM
Gravatar
Total Posts 18444

Re: File upload doesn't work in mono 1.1.8

Hmm, it seems to do that in IE but not Firefox on this site which is using mono 1.1.7

I had forgot you were back at 1.1.7, the topic of this thread is 1.1.8 after all

I'll try it on the latest mono code when I get a chance and post again.
You must sign in to post in the forums. This thread is closed to new posts.