Columnar content templates not working as expected

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
4/27/2017 12:51:08 PM
Gravatar
Total Posts 13

Columnar content templates not working as expected

I just created a site with 2.5.0.0 and tried to set up  some text using the 2 over 1 content template and it didn't work. I tried 3 over 1 and 4 over 1 and neither worked. I just set up a test page on the demo site and the same problem. The other templates for acordion and tab work OK it just seems to be the ones using columns. They just seem to line up one on top of another irrespective of screen size.

 

 

4/27/2017 1:14:49 PM
Gravatar
Total Posts 1992

Re: Columnar content templates not working as expected

Hi Stephen,

Thank you for pointing this out. We haven't used those ourselves in a very, very long time so we kind of forgot about them. The next release will have a way to import and export content templates and these will not show up by default. Having hardcoded templates is kind of dirty anyway.

I'll put together some replacements you can use.

Thanks,
Joe

 

4/27/2017 3:41:12 PM
Gravatar
Total Posts 1992

Re: Columnar content templates not working as expected

Hi Stephen,

You can see some new content templates that will work with bootstrap based skins here. You'll need to login to see those. The demo site login is admin@admin.com and the password is admin

The next release will include a way to import/export content templates. The old templates you're referring to are hardcoded and they require custom CSS to work. It's best if the content templates work based on what the skin can do rather than adding bloat to every skin to support old markup and css coding styles.

Thanks,
Joe 

 

4/28/2017 4:14:41 AM
Gravatar
Total Posts 13

Re: Columnar content templates not working as expected

Thanks Joe. I've always found the old ones quite handy but time moves on I guess!

4/28/2017 12:48:56 PM
Gravatar
Total Posts 1992

Re: Columnar content templates not working as expected

Hi Stephen,

You could add the following CSS to your skin to make the old templates work.

.floatpanel  {
    float: left;
    margin-right: 15px
}

.clear {
    clear: both;
}

Thanks,
Joe