Confusing returnURL after sign-in with email confirmation

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
3/21/2015 9:44:15 AM
Gravatar
Total Posts 503
feet planted firmly on the ground

Confusing returnURL after sign-in with email confirmation

If we configure a site to require email verification on registration, the user follows the link in the email to a page like /ConfirmRegistration.aspx?ticket=aceeb89e-6c6f-4528-9011-9115e76391bc

They see instructions telling them to sign in with the link above. This link adds a returnURL like

/Secure/Login.aspx?returnurl=%2fConfirmRegistration.aspx%3fticket%3daceeb89e-6c6f-4528-9011-9115e76391bc

so when the user has signed in they are returned to a page telling them they can sign in using the link above.

It would be better if the "Sign In" link on ConfirmRegistration.aspx did not include the returnURL.

3/23/2015 10:59:25 AM
Gravatar
Total Posts 18444

Re: Confusing returnURL after sign-in with email confirmation

This is now fixed in the source code repository so it will be fixed in the next release.

Thanks,

Joe

You must sign in to post in the forums. This thread is closed to new posts.