Mobile Kit Pro 2.0: No menu display on Win8 Phones

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
7/16/2014 8:47:30 PM
Gravatar
Total Posts 182

Mobile Kit Pro 2.0: No menu display on Win8 Phones

Win 2008, SQL 2008, Mojo 2.4.0.3, .net 4.5

The latest build of Mobile Kit Pro (2.0) is broken on Windows Phone. The nav menu does not show any text labels for the nav. I tried the two bundled skins and neither show any of the navigation button labels. The buttons try to appear, but no text.... thus they can not be selected.

Reverting to the 1.2 build fixes the issue, so it's something that changed in the latest version. I poked around a little but couldn't find the problem. I have a Windows Phone (Love it) and would be happy to help with testing.

7/17/2014 7:49:14 AM
Gravatar
Total Posts 18444

Re: Mobile Kit Pro 2.0: No menu display on Win8 Phones

does the problem happen on our demo site?

is anything being logged when the problem happens on your site?

does the problem happen on your site with both of the included skins in Mobile Kit Pro?

7/17/2014 4:26:59 PM
Gravatar
Total Posts 1991

Re: Mobile Kit Pro 2.0: No menu display on Win8 Phones

I'm running Win8.1 and the menu is working fine for me on the demo site and the mojoPortal.com site.

7/17/2014 4:34:20 PM
Gravatar
Total Posts 182

Re: Mobile Kit Pro 2.0: No menu display on Win8 Phones

Yea, I see it fine on the mojo site as well (8.1 here as well). I'm not sure why both the included skins are not working on my site. I have not had a chance to dig deeper (will this evening). I'll post what I figure out, must be on my end.

7/18/2014 6:40:09 AM
Gravatar
Total Posts 18444

Re: Mobile Kit Pro 2.0: No menu display on Win8 Phones

make sure you deployed the javascript included in the Mobile Kit Pro package as instructed in the readme.txt.

7/18/2014 9:18:59 PM
Gravatar
Total Posts 182

Re: Mobile Kit Pro 2.0: No menu display on Win8 Phones

Ah, that was the problem. I needed to place the knockout js file in ClientScript folder. All better now.

A good reminder to always read the read me. Thanks!!

You must sign in to post in the forums. This thread is closed to new posts.