Tree Menu obscure bug for Content Administrators

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
5/9/2013 6:22:07 AM
Gravatar
Total Posts 121

Tree Menu obscure bug for Content Administrators

Colleagues working on a site with a tree menu reported an issue that we've now tracked down to a bug. Certain nodes in the menu were not getting their "+/-" symbol to collapse the node, even though they did have pages beneath.

It turned out this happens if a) all the sub-pages have their view permissions set to only Admins and Content Admins and no other roles, and b) the logged in user is a Content Administrator but not an Administrator.  If a full administrator logs in, the expand/collapse link appears no problem.

I've checked the html - this is not a styling issue, it really is the case that the markup for the expand/collapse link is not present.

5/13/2013 9:37:19 AM
Gravatar
Total Posts 18439

Re: Tree Menu obscure bug for Content Administrators

I've logged this in our project tracker to investigate when I have time.

Best,

Joe

You must sign in to post in the forums. This thread is closed to new posts.