Google Reader doesn't like the RSS of the forums

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
2/21/2013 11:49:46 AM
Gravatar
Total Posts 249

Google Reader doesn't like the RSS of the forums

I follow the forums using Google Reader.

What happens is, that, even if the RSS XML has the right links for the title, Google Reader does not give the right URL

For example, the RSS of the bugs reporting forum

The URL http://www.mojoportal.com/Forums/Thread.aspx?pageid=5&t=11403~-1#post47465

becomes

http://www.mojoportal.com/Forums/Thread.aspx?pageid=

Here is a shot of my Google Reader

http://i.imgur.com/AwZlZmG.png

2/21/2013 12:05:51 PM
Gravatar
Total Posts 18439

Re: Google Reader doesn't like the RSS of the forums

The feed has valid link urls in it so I don't see it as a bug in mojoPortal, seems more like a bug in google reader. 

2/21/2013 12:23:14 PM
Gravatar
Total Posts 249

Re: Google Reader doesn't like the RSS of the forums

Yes, the feed is valid, but that doesn't happen with older versions of mojoportal

For example, with this feed produced by a three years old mojoportal install (2.3.5.x), google reader behaves correctly:

ja.       dandandin      .it    /Forums/RSS.aspx?ItemID=1&mid=7&pageid=3

(spaces inserted as I don't want that spambots get this empty testing forum)

The XML is almost the same, so I don't understand why it behaves like this, maybe google reader doesn't like tildes in URLs?

So bad, because I have the feeling that google reader is becoming an abandoned project  as it's getting buried in the top menu

2/21/2013 1:45:19 PM
Gravatar
Total Posts 18439

Re: Google Reader doesn't like the RSS of the forums

The old parameters still work but are not preferred. Maybe I can detect the user agent for the google feed reader (Feedfetcher-Google) and make it use the old params in that case. I'll see what I can do.

Best,

Joe

3/1/2013 4:30:48 PM
Gravatar
Total Posts 18439

Re: Google Reader doesn't like the RSS of the forums

Can you check it again using our forum feed from this site and let me know if it is working better now?

I made the change to detect google feed reader and use the old param format.

Thanks,

Joe

3/1/2013 4:40:54 PM
Gravatar
Total Posts 249

Re: Google Reader doesn't like the RSS of the forums

No, it's the same

http://imgur.com/6XfQ55Y

​Maybe Google is caching the rss (I deleted it and readded it)

edit: yes, i think Google is caching the rss and fetching only in "common hours" as for my website I see only one entry for Google Reader in the log

2013-03-01 01:14:51 GET /Forums/RSS.aspx mid=3&pageid=2 209.85.238.237 Feedfetcher-Google;+(+http://www.google.com/feedfetcher.html;+1+subscribers;+feed-id=*7751) - 200 0 68366 310 890

2013-03-01 05:02:39 GET /Forums/RSS.aspx mid=3&pageid=2 209.85.238.237 Feedfetcher-Google;+(+http://www.google.com/feedfetcher.html;+1+subscribers;+feed-id=*7751) - 200 0 68366 310 1171

2013-03-01 07:59:00 GET /Forums/RSS.aspx mid=3&pageid=2 209.85.238.237 Feedfetcher-Google;+(+http://www.google.com/feedfetcher.html;+1+subscribers;+feed-id=*7751) - 200 0 68366 310 1531

2013-03-01 11:04:59 GET /Forums/RSS.aspx mid=3&pageid=2 209.85.238.237 Feedfetcher-Google;+(+http://www.google.com/feedfetcher.html;+1+subscribers;+feed-id=*7751) - 200 0 68366 310 921

(see? it skipped the night time, usually there is no activity in my forum)

 

Ps: I couldn't login using Firefox (login loop), something is messed with my cookies?

3/6/2013 6:35:16 AM
Gravatar
Total Posts 249

Re: Google Reader doesn't like the RSS of the forums

No, it looks like it's a different google reader problem

I can't understand why

I saw slashdot rss has tildes in the rss, but it works fine, so the problem must be another one.

3/14/2013 5:51:18 AM
Gravatar
Total Posts 18439

Re: Google Reader doesn't like the RSS of the forums

I guess trying to solve this is a moot point. Google reader has a popup this morning saying it is going away in July. I'm going to have to look around for an alternative.

3/14/2013 5:57:51 AM
Gravatar
Total Posts 249

Re: Google Reader doesn't like the RSS of the forums

NOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

My favorite website!!!!!!!!!!!!!!!!!!!!

NOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

They killed all the alternatives and now they disappear!!!!!

NOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

I guess my employer would be super happy, according to rescuetime Google Reader is the #1 source of distraction for me

3/14/2013 6:05:39 AM
Gravatar
Total Posts 18439

Re: Google Reader doesn't like the RSS of the forums

going to have to explore the alternatives to google reader

3/14/2013 6:27:09 AM
Gravatar
Total Posts 18439

Re: Google Reader doesn't like the RSS of the forums

and feedeemon is also not going to be maintained further.

You must sign in to post in the forums. This thread is closed to new posts.