web.config validateIntegratedModeConfiguration not working - SOLUTION

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
4/25/2012 11:33:11 PM
Gravatar
Total Posts 215

web.config validateIntegratedModeConfiguration not working - SOLUTION

With the upgrade to 2.3.8.5 I noticed errors where I was running some legacy Classic ASP/.NET code that read like this:

An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

The error message told me to add this code to the system.webserver section of the web.config.
validation validateIntegratedModeConfiguration="false"
The code was already in there, so that didn't help.

After lots of research and trying different things I found this article and the solution. I changed the web.config as instructed and the error went away.
http://runtingsproper.blogspot.com/2010/04/solved-iis7-validateintegratedmodeconfi.html

 

Go into the Mojo web.config, find the system.webServer area and change this code:

<location inheritInChildApplications="false">    
<system.webServer>      
   <!-- Disable runtime rejection of Integrated mode applications that have legacy ASP.NET settings -->      
   <validation validateIntegratedModeConfiguration="false"/>      
   <defaultDocument>        
     <files>

TO THIS  

 <system.webServer>    
   <!-- Disable runtime rejection of Integrated mode applications that have legacy ASP.NET settings -->    
   <validation validateIntegratedModeConfiguration="false" />  
</system.webServer>

<location inheritInChildApplications="false">    
<system.webServer>      
  <defaultDocument>        
    <files>

Basically you have to add a second <system.webServer> section with just the validateIntegratedModeConfiguration="false" inside of it. The link above explains why this was necessary.

Joe, could you change this on your end or consider one of the other work-arounds mentioned in the article? I bet anyone running legacy code inside the same app pool will have this problem going forward otherwise (as of version 2.3.8.5). It appears that the newly added <location inheritInChildApplications="false"> code is cancelling out the validateIntegratedModeConfiguration="false"

Hope this helps someone else!

4/26/2012 7:47:57 AM
Gravatar
Total Posts 18439

Re: web.config validateIntegratedModeConfiguration not working - SOLUTION

Hi Eric,

Thanks! That is a good tip. I had actually removed the location wrappers from our full trust web.config files because it caused a problem with NeatUpload, I had kept them in the ones for medium trust since NeatUpload can't be used there anyway.

Now I'll have to test if maybe this solution will solve the neatupload problem, then I could put the location wrappers back in the full trust web.config files.

We have the MS SQL relkease packages pre-configured for medium trust since that is what most shared hosting uses and because they require that for our package in the web app gallery.

Best,

Joe

4/26/2012 9:06:13 AM
Gravatar
Total Posts 18439

Re: web.config validateIntegratedModeConfiguration not working - SOLUTION

In follow up that did solve the problem with NeatUpload so I'll be able to include the location wrappers in the full trust web.config files going forward.

Thanks,

Joe

4/26/2012 11:17:21 AM
Gravatar
Total Posts 215

Re: web.config validateIntegratedModeConfiguration not working - SOLUTION

Thanks Joe, glad I could help a little!

4/30/2012 1:50:47 PM
Gravatar
Total Posts 28

Re: web.config validateIntegratedModeConfiguration not working - SOLUTION

Hello; What can I do for this problem. In the Web.config file
http://www.moduled.com.tr have this problem on this site
Waiting for your help regards,

 

4/30/2012 2:16:00 PM
Gravatar
Total Posts 28

Re: web.config validateIntegratedModeConfiguration not working - SOLUTION

The answer to the error above, there According to him figured out the problem.
Thank you, Eric and Joe
Sincerely

You must sign in to post in the forums. This thread is closed to new posts.