Backgroiund image does not appear when specifying in style.css

A place for discussion about skinning and design. Before posting questions here you should review the documentation about creating skins.

This thread is closed to new posts. You must sign in to post in the forums.
9/11/2011 5:37:03 PM
Gravatar
Total Posts 21

Backgroiund image does not appear when specifying in style.css

I have disabled CSS and browser caching. I have set CombineCSS and MinifyCSS to false. I am using Firebug to locate the css rules that I need to change.

The line I am changing is:
background-image: url('images/Bottom_texture.jpg');

I change it to:
background-image: url('images/Transloo_BG.jpg');

I hit <CTRL><F5> in Firefox and the original background image does indeed disappear. However, my new background image does not appear and Firefox states that it "Failed to load the given URL".

Both images are found in the following directory:
wwwroot\Data\skins\magian-transloo-01\images

I am dying to get started so any help is appreciated.

 

9/12/2011 10:53:30 AM
Gravatar
Total Posts 1188
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: Backgroiund image does not appear when specifying in style.css

Hi, the path you quoted is actually pointing to the delivered skin repository directory. These skins aren't "live"--they are the source from which you can copy skins for each site. mojoPortal delivers update skins to this directory only, so that any customized skins you have won't be overwritten during upgrades.

The skins that are live for each site are located under Data\sites\[Site#]\skins\[SkinName], and that's where you would make CSS and image changes to update them. So to make a change to your skin, you should place your new images in (for example):

Data\sites\1\skins\magian-transloo-01\images

Hope that helps,
Jamie

9/12/2011 2:09:15 PM
Gravatar
Total Posts 18444

Re: Backgroiund image does not appear when specifying in style.css

Note also that when you set CombineCSS to false then it just adds links to each of the css files listed in your style.config and in that case there is nothing to prevent the browser from caching it since it is just static files. Only when we combine all the css and serve it from csshandler.ashx can we control the cache. So you haven't really disabled the cache if you have CombineCSS = false.

If you are using Firebug then the way to troubleshoot the problem is to use the network tab in Firebug to see if it is even making a request for your image and also what the status code for that request is. There you could find out if it can't find the file or can't load it because of permissions.

Hope that helps,

Joe

9/12/2011 9:41:51 PM
Gravatar
Total Posts 21

Re: Backgroiund image does not appear when specifying in style.css

Thank you both for the fix and the advice.

You must sign in to post in the forums. This thread is closed to new posts.