V2.3.6.6 Parser error in Admin/PageSettings.aspx

A place for discussion about skinning and design. Before posting questions here you should review the documentation about creating skins.

This thread is closed to new posts. You must sign in to post in the forums.
6/16/2011 2:52:48 PM
Gravatar
Total Posts 114

V2.3.6.6 Parser error in Admin/PageSettings.aspx

I see that from V2.3.6.4, we need this in Layout.Master:<body class="pagebody" id="Body" runat="server">

<body class="pagebody" id="Body" runat="server">

That is present as required; but now, when I go to do page settings from the admin menu, I get the following parser error, regardless of which development server I use (VS or IISExpress):

Parser Error Message: Unknown server tag 'portal:SkinList'.

Source Error:



Line 83:                                     <mp:SiteLabel ID="lblSkin" runat="server" ForControl="ddSkins" CssClass="settinglabel"
Line 84:                                         ConfigKey="SiteSettingsSiteSkinLabel"></mp:SiteLabel>
Line 85:                                     <portal:SkinList id="SkinSetting" runat="server" AddSiteDefaultOption="true" />
Line 86:                                     <portal:mojoHelpLink ID="MojoHelpLink7" runat="server" HelpKey="pagesettingsskinhelp" />
Line 87:                                 </div>

Source File: /Admin/PageSettings.aspx    Line: 85

This is a plain vanilla, unmodified V2.3.6.6, as released. Any idea why I'm getting this?

Thanks in advance!

Duane Doutel

<body class="pagebody" id="Body" runat="serv

6/16/2011 3:07:31 PM
Gravatar
Total Posts 1196
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: V2.3.6.6 Parser error in Admin/PageSettings.aspx

I had this problem too. There's a new entry needed in Web.config. Joe helped me with it in this thread. The hazards of developing from source and merging web.config! smiley If you're not working from the source code, you may not have taken the new web.config and merged your customizations into it (machine key, etc.) as you should at each upgrade.

In my copy and the repository copy it should have this in the <pages><controls> section of Web.config:

<add tagPrefix="portal" tagName="SkinList" src="~/Controls/SkinSetting.ascx"/>

reverting your copy and restoring customizations should solve it, or just adding that to your copy.

Jamie

6/16/2011 3:11:11 PM
Gravatar
Total Posts 1196
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: V2.3.6.6 Parser error in Admin/PageSettings.aspx

Joe, what would you think about tracking Web.config changes and putting those in either the sticky "important skin changes" thread or another similar one? Seems like it could be useful.

Jamie

6/16/2011 3:18:06 PM
Gravatar
Total Posts 114

Re: V2.3.6.6 Parser error in Admin/PageSettings.aspx

Hey, Jamie! Thanks; I'll fix that right away. FWIW, this IS a 2.3.6.6 web.config, taken directly from the distribution, so I have no idea why this should be missing...

Many thanks!

Duane

 

6/16/2011 3:35:16 PM
Gravatar
Total Posts 18439

Re: V2.3.6.6 Parser error in Admin/PageSettings.aspx

Hi Duane,

this IS a 2.3.6.6 web.config, taken directly from the distribution, so I have no idea why this should be missing...

No, I beg to differ, the 2.3.6.6 packages have this in Web.config

Hi Jamie,

I don't see Web.config changes the same as skin changes and don't want to post a list of changes because although not that frequent they can be complicated sometimes and I don't want people thinking it is safe to keep their old one. Not to mention there are different versions for .NET 3.5 and .NET 4.

People using release packages should always use the Web.config that ships in the package and restore their customizations after upgrades.

Those working from the source code repository should keep an eye out for merge conflicts and periodically revert and restore their customizations if needed. As far as I understand you've been working from the repository for a long time and this is the first time you've reported any kind of merge conflict causing an error. I don't see it as something that needs a further solution or more attention right now.

Best,

Joe

6/16/2011 5:09:09 PM
Gravatar
Total Posts 114

Re: V2.3.6.6 Parser error in Admin/PageSettings.aspx

Joe, let me clarify; I wasn't "pointing fingers". I have had this version of mojoPortal running locally for development and in the wild since this last weekend; everything's been working fine in both environments. I'm just skinning, not working with the source. Both environments had been taken from the same 2.3.6.6 mssql drop.

Earlier today, I went to change a page setting in my dev environment, and got the error reported. I was not getting the same error in the wild, only in dev. I had no clue what was causing it, so came here to ask about it. Since I had not modified web.config since installing either environment (all my customizations end up in user.config, and haven't had it up in the VStudio since installing), when Jamie pointed me at the solution, I could not understand why that tag had gone missing in my dev environment. Please note, I did NOT say you left it out! Clearly, it was NOT missing in the wild, since I was not getting the error there. It had GONE missing locally, and I had no idea why.

I keep using mojoPortal because it's a consistently fine product. Why would you even think I'd antagonize you for something niggling like this, or anything at all, for that matter? Peace, my friend! :)

Duane

 

 

6/16/2011 5:20:39 PM
Gravatar
Total Posts 18439

Re: V2.3.6.6 Parser error in Admin/PageSettings.aspx

Hi Duane,

Sorry, I did not at all take you as antagonistic. I just answered quickly.

I have no idea about your environment or why it is different than it should be, I was just saying that in fact, the packages have the correct setting in Web.config and therefore if you are using the one from the package it should not have thrown this error.

I didn't mean to sound terse, I probably should have waited until tomorrow to answer, this is after hours for me, but I did answer because I do want to be helpful, but I answered in a hurry (because I already worked a full day and want to be done for the day) and perhaps sounded terse unintentionally.

I'm at peace and wish you the same my friend.

Best,

Joe

You must sign in to post in the forums. This thread is closed to new posts.