Visual studio bogging down

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

Please do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.

This forum is for discussing mojoPortal development

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

You can monitor commits to the repository from this page. We also recommend developers to subscribe to email notifications in the developer forum as occasionally important things are announced.

Before posting questions here you might want to review the developer documentation.

Do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.
This thread is closed to new posts. You must sign in to post in the forums.
5/24/2011 1:36:00 AM
Gravatar
Total Posts 111
Matt Millican InternetMill

Visual studio bogging down

Hi all,

I know this may be a bit of a general question but I wanted to put some feelers out there...

Over the past few days, I've noticed that when I have mojoPortal open in VS 2010 (Ultimate) it's been getting extremely bogged down and will start using about 50% of my CPU (I have an i5, 3.2GHz with 6g of RAM).  It gets so bad that I can hear my fans speed up (which I can almost never hear) when building and browsing the site locally.

I'm not sure if something changed in my settings, or what, but I wanted to throw it out there.  I did a repair install of VS 2010 tonight as well.

Thanks,

Matt

5/24/2011 7:55:34 AM
Gravatar
Total Posts 111
Matt Millican InternetMill

Re: Visual studio bogging down

I also wanted to mention that it has just recently started doing this.  I moved all of my extra projects to .net 4.0 a couple weeks ago and that all went on without any problems.  It's just over the past couple days.  Also, it seems like it starts out fine for a while and then gets progressively worse in a session.  As soon as I close it, the CPU jumps back to 0-1%.

5/24/2011 8:04:30 AM
Gravatar
Total Posts 18439

Re: Visual studio bogging down

Are you working in the debugger all the time? That makes things much slower, I only use the debugger when I actually need to step through code. You can run the VS web server or IIS without debugging. ie to use the VS Web server (assuming everything has been built at least once), right click the Default.aspx file in the root of the Web folder and choose view in browser, this will launch the page in VS web server.

Then as I make changes in development I just build the project I'm editing and then refresh the page in the browser. The only time I need to use the debugger is when something isn't working as expected and I want to step through it to find out what is happening.

Visual Studio is a beast though, it does use a lot of resources and the more you have the better it works, fast hard drives are a big help. You can help them improve it by installing this performance monitor for VS.

Hope that helps,

Joe

5/24/2011 8:34:26 AM
Gravatar
Total Posts 111
Matt Millican InternetMill

Re: Visual studio bogging down

No, I do the same thing with the debugger, only using it when I need to step and trace.  I actually don't even want to see what the debugger would do to it right now haha.

I'll try that perf mon for VS tonight when I get home.

Thanks, Joe!

5/24/2011 9:49:16 AM
Gravatar
Total Posts 1204
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: Visual studio bogging down

If you haven't already, you might want to install Service Pack 1, just in case it's a bug in VS that's causing this.

Jamie

5/24/2011 12:28:45 PM
Gravatar
Total Posts 111
Matt Millican InternetMill

Re: Visual studio bogging down

Hey Jamie,

I actually had it installed (that was my other recent change) and was wondering if it was causing an issue so I uninstalled it.  

I don't know if any of you are familiar with it, but I've been using an add-on for Visual Studio called ReSharper, and I'm starting to think that's what it might be, but not sure.  I need to do some investigation tonight when I get home.

It is getting to be the reformat time of year *sigh* but I'm trying to put it off because I'd rather develop than worry about installing and configuring everything.

I'll let you know what I find tonight when I get home.

Thanks,

Matt

5/25/2011 9:58:15 AM
Gravatar
Total Posts 18439

Re: Visual studio bogging down

ReSharper is a nice tool but it can definitely slow things down, a quick google of resharper slows down visual studio finds a number of complaints about it.

Best,

Joe

5/25/2011 12:49:58 PM
Gravatar
Total Posts 111
Matt Millican InternetMill

Re: Visual studio bogging down

After I thought about it for a while I figured it must be that it's trying to load so much into its intellisense.  I have several large projects but obviously mojoPortal is much larger.  I didn't get home in time last night to really do much work at all last night so tonight I'm going to reinstall SP1 and perfmon and see how that does.

Thanks Joe!

You must sign in to post in the forums. This thread is closed to new posts.