Gallery images display issue

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
5/2/2011 12:28:20 PM
Gravatar
Total Posts 63

Gallery images display issue

If I use Sliverlight to display photos in Photo Gallery, then everything is fine. If I display photo thumbnails, then upon click, the image does not display correctly. The photo does not stay on top of the page, and the height is not correct. To see what I am talking about, please visit one of my customers' page, then click on a thumbnail under Fellowship: http://www.lubbockchinesechurch.org/photo-gallery.aspx

 

Thanks for your help,

5/2/2011 12:53:28 PM
Gravatar
Total Posts 2202

Re: Gallery images display issue

Hi,

See the notes for 2.3.6.4 in the Important Skin Changes thread.

We are now using ColorBox instead of Greybox for the image gallery slideshows.

HTH,
Joe D.

5/2/2011 1:22:16 PM
Gravatar
Total Posts 63

Re: Gallery images display issue

Thanks Joe. That fixed part of the problem. As you see in the photo gallery page, I have two Photo Gallery instances. The top one is using SilverLight to slide show the photos automatically, and the bottom one is using ColorBox. Now the Colorbox is showing the pictures, but the pictures are behind the  SilverLight slide show. Is it a z-index issue?

Regards,

5/3/2011 7:08:01 AM
Gravatar
Total Posts 18439

Re: Gallery images display issue

I have a feeling it just isn't going to work well having both the silverlight slide show and a regular gallery with colorbox effects on the same page. There is a setting (look in settings) to Make The Silverlight Slide show windowless that "might" help but I'm not sure that will solve it.

Best,

Joe

5/3/2011 8:27:40 AM
Gravatar
Total Posts 63

Re: Gallery images display issue

Thank you Joe. This is what I end up doing.

1. Make the silverlight slide show Windowless as you suggested.

2. Make the color box's opacity = 1 to hide the background when the color box is displaying images because the silverlight slide show never stops even when the color box is showing the images.

This workaround seems to work for me.

Regards,

You must sign in to post in the forums. This thread is closed to new posts.