Captchar image not shown but the red cross of image holder

This is an open forum for any mojoPortal topics that don't fall into the other categories.

This thread is closed to new posts. You must sign in to post in the forums.
12/24/2010 7:33:13 AM
Gravatar
Total Posts 8

Captchar image not shown but the red cross of image holder

Hello,

I'm new to mojoPortal. I have added the contact form on my web page. But when I want to send the contact form the Captchar code is just the red cross. Anybody have an idea how to solve this? I am using 2.3.5.5 hosted at arvixe.com

12/24/2010 8:25:50 AM
Gravatar
Total Posts 18439

Re: Captchar image not shown but the red cross of image holder

Do you see any related errors in the mojoPortal log?

http://www.mojoportal.com/basic-troubleshooting.aspx

 

12/24/2010 8:39:55 AM
Gravatar
Total Posts 8

Re: Captchar image not shown but the red cross of image holder

Thanks Joe for your reply,

 

2010-12-24 08:36:10,570 ERROR mojoPortal.Web.Global - 202.80.245.10-th-TH - /Data/Sites/1/skins/artisteer-24verticalmenu2/csshandler.ashx?skin=artisteer-24verticalmenu2
System.Web.HttpException: The file '/Data/Sites/1/skins/artisteer-24verticalmenu2/csshandler.ashx' does not exist.
 

 

Is above ERROR related to my problem?

12/24/2010 8:54:29 AM
Gravatar
Total Posts 18439

Re: Captchar image not shown but the red cross of image holder

That is a similar error but not related to the captcha, you should clear the log then cause the captcha error then look in the log again and you will probably see a similar error for CaptchaImage.ashx

It means that .ashx extension is not configured correctly on the server or IIS is configured to return a 404 without letting .NET code handle the request for .ashx files that do not exist.

It is true that the file does not exist but the file does not need to exist because it is mapped from Web.config like this:

<add name="SubkismetCaptchaHandler" verb="*" path="*CaptchaImage.ashx" type="Subkismet.Captcha.CaptchaImageHandler, Subkismet" preCondition="integratedMode"/>

and csshandler.ashx is mapped like this:

 <add name="CssHandler" verb="*" path="*csshandler.ashx" type="mojoPortal.Web.UI.CssHandler, mojoPortal.Web" preCondition="integratedMode"/>

so it is a server configuration issue and you may need to get help from your host to resolve it.

see also this related thread, it has a screen shot from IIS 6 showing the extension mappings.

Also I can tell from the paths in your error that you are using a very old version of mojoPortal, it would be better to use the latest version if possible.

Hope it helps,

Joe

 

12/24/2010 9:12:42 AM
Gravatar
Total Posts 8

Re: Captchar image not shown but the red cross of image holder

He Joe,

 

Arvixe provides 3.5.5.5 which does not sound very old. BTW I got this hopefully more accurate Error log

 

2010-12-24 10:06:01,308 ERROR mojoPortal.Web.Global - 202.80.245.10-th-TH - /CaptchaImage.ashx?spec=%2fQpRHdTIOlNRyaSfWIoBsetB4j%2fmzYq4qUzVSBoPoy%2btzyrtz6zzEG6gUxpNv1M0
System.Web.HttpException: The file '/CaptchaImage.ashx' does not exist.
at System.Web.UI.Util.CheckVirtualFileExists(VirtualPath virtualPath)
at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
at System.Web.Compilation.BuildManager.GetVPathBuildResult(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile)
at System.Web.UI.SimpleHandlerFactory.System.Web.IHttpHandlerFactory2.GetHandler(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath)
at System.Web.UI.SimpleHandlerFactory.GetHandler(HttpContext context, String requestType, String virtualPath, String path)
at System.Web.HttpApplication.MaterializeHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

 

Do you have more suggestion or you advise me to go to 3.5.5.8? And in that case how do I do so?

 

Br, Thada
 

12/24/2010 9:30:49 AM
Gravatar
Total Posts 18439

Re: Captchar image not shown but the red cross of image holder

Arvixe provides the version that is in the Web App Gallery which is currently 2.3.5.5 and this is not an old version, but I think you do not have this version because in your error you have the path

"/Data/Sites/1/skins/artisteer-24verticalmenu2/csshandler.ashx?skin=artisteer-24verticalmenu2"

but in newer versions of mojoPortal this is not the path used for csshandler.ashx, it should be like a root level path without /Data/Sites/1/skins

You can find the mojoPortal version under Administration > System Information

In any case the problem is still as I mentioned that .ashx files need to be configured to be handled by .NET and IIS should not return a 404 if the file does not exist, it can only be solved by server configuration.

I would try to get Arvixe to help with this problem before upgrading, then if you want to upgrade after the problem is solved see the upgrading documentation. I would not complicate the problem by upgrading but solve the problem first then upgrade if you want to after solving this problem, it is a server configuration issue.

Hope it helps,

Joe

12/24/2010 6:38:34 PM
Gravatar
Total Posts 8

Re: Captchar image not shown but the red cross of image holder

Hi Joe,

Below is the System info. I install this from arvixe web app gallery.

mojoPortal Version 2.3.5.5 MSSQL
Operating System Microsoft Windows NT 6.0.6002 Service Pack 2
ASP.NET Info v2.0.50727 Running in Full Trust
Server Time Zone Eastern Standard Time
Server Local Time (GMT -5) 24/12/2553 19:18:53
Greenwich Mean Time (GMT/UTC) 25/12/2553 0:18:53

 

Thanks for your trying to solve this with arvixe.

You have been of great helps,

Thada
 

12/26/2010 10:33:02 AM
Gravatar
Total Posts 9

Re: Captchar image not shown but the red cross of image holder

Hi,

This was resolved over ticket. Looks like the issue was that the web.config had some items in it that shouldn't of been in it and also the ASP.NET version was incorrect. The captcha is now working as expected.

Regards,

Avesta @ Arvixe

 

 

12/26/2010 5:37:58 PM
Gravatar
Total Posts 8

Re: Captchar image not shown but the red cross of image holder

Hello,

Thanks a lot guys. I switched from my ex-hosting company to Arvixe hoping  to run mojoPortal smoothly. And you do not disappoint.

Thanks again,

LP Thada

PS Over the next few weeks my www.mooncurve.org will have more content for English audience for sure.

12/27/2010 10:05:59 AM
Gravatar
Total Posts 1204
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: Captchar image not shown but the red cross of image holder

Thanks for sharing. I really enjoyed the photo galleries--it's a very beautiful place!

You must sign in to post in the forums. This thread is closed to new posts.