Strange sign in/out problem after upgrade to 2.3.5.5

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
12/10/2010 12:25:16 PM
Gravatar
Total Posts 60

Strange sign in/out problem after upgrade to 2.3.5.5

Hi All,

I've just upgraded a couple of our sites from 2.3.3.4 MSSQL/IIS to 2.3.5.5/asp.net 4, and I now have a strange problem to do with being signed-in:

  • If I go to, for example, the home page, it shows me as being signed-out, even if I previously signed-in and told it to remember.  
  • If I then click on Sign-In, the page refreshes and I can see myself as signed-in without having to actually go through the sign-in page.  
  • If I click on another menu it takes me to the page (or refreshes the home page) but I'll appear as signed-out again.
  • I have certain pages that can only be seen by logged-in users.  These are visible when I've clicked on the sign-in link as detailed above, but if I click on one one of those menus it takes me back to the home page signed-out again.

I've tried a number of skins (including ones that came with the latest version) but it made no difference.

For one site I started from scratch with a get of the 2.3.3.5 and just dropped the old skin files in (and tweaked them).  For the other site I dropped the new files (minus site skins) over the existing site files.

I've had a rummage through the forum and can't anyone reporting a similar problem (apologies if I've missed it though) - any ideas?

Thanks

Ian

12/10/2010 12:33:24 PM
Gravatar
Total Posts 2212

Re: Strange sign in/out problem after upgrade to 2.3.5.5

Hi Ian,

I have seen this happen when the site is configured for extensionless urls but this setting isn't set in the web.config:

<modules runAllManagedModulesForAllRequests="true">

HTH,
Joe D.

12/10/2010 12:39:05 PM
Gravatar
Total Posts 60

Re: Strange sign in/out problem after upgrade to 2.3.5.5

That was it!

Marvellous - thanks for the almost instantaneous response!

Ian

You must sign in to post in the forums. This thread is closed to new posts.