Help with evaluating mojoPortal

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
3/21/2005 11:45:41 PM
Gravatar
Total Posts 92

Re: Help with evaluating mojoPortal

On a newly installed Fedora Core 2 server, with a functioning apache-2.0.51-3.0, mysql-server-4.1.8-1 and mono-1.0.6-1.novell.9.1 I'm experiencing the following error.

Server error in '/mojoportal' application
Description: Error processing request.

Error Message: HTTP 500.
Stack Trace:

System.NullReferenceException: Object reference not set to an instance of an object
in <0x000d1> mojoPortal.Web.MasterPage:.ctor ()
in <0x00031> ASP.Default_aspx:__BuildControl_MPContainer ()
in <0x0001f> ASP.Default_aspx:__BuildControlTree (System.Web.UI.Control)
in <0x00025> ASP.Default_aspx:FrameworkInitialize ()
in <0x0009e> System.Web.UI.Page:ProcessRequest (System.Web.HttpContext)
in <0x002eb> ExecuteHandlerState:Execute ()
in <0x00084> StateMachine:ExecuteState (System.Web.HttpApplication/IStateHandler,bool)

My web.config file has the following changes made to it.

I can log into the mojoportal database and select * from the tables when logged in as mojo with the password mojo.

Any advice? Do you need any more information??? I'm looking for a base to start an extranet with a lot of custom modules and mojoPortal and Cuyahoga both look promising, and I'm leaning towards mojoPortal if I can get it working for testing.

Thanks.
3/22/2005 3:58:19 AM
Gravatar
Total Posts 18444

Re: Help with evaluating mojoPortal

There was a bug in the release files that I fixed last night, if you downloaded prior to then please download again and let me know if that doesn't resolve the problem.
3/22/2005 6:28:34 AM
Gravatar
Total Posts 92

Re: Help with evaluating mojoPortal

I downloaded cvs revision 100, compiled, deleted the server copy, uploaded my new copy, dropped the mysql mojoportal database, created a new mojoportal database, ran the 1, 2, 3, 4 sql scripts.
I commented out "ConnectionString", "postgresqlConnectionString" and "PostgreSQLConnectionString" keys in the Web.config file and configured the "mySqlConnectionString" key to my MySql settings.
Stopped and restarted Apache and I get the same error.
7
Description: Error processing request.

Error Message: HTTP 500.
Stack Trace:

System.NullReferenceException: Object reference not set to an instance of an object
in <0x000d1> mojoPortal.Web.MasterPage:.ctor ()
in <0x00031> ASP.Default_aspx:__BuildControl_MPContainer ()
in <0x0001f> ASP.Default_aspx:__BuildControlTree (System.Web.UI.Control)
in <0x00025> ASP.Default_aspx:FrameworkInitialize ()
in <0x0009e> System.Web.UI.Page:ProcessRequest (System.Web.HttpContext)
in <0x002eb> ExecuteHandlerState:Execute ()
in <0x00084> StateMachine:ExecuteState (System.Web.HttpApplication/IStateHandler,bool&)

How does it know what database to use (MySQL, PostgreSQL or MS SQL???) because I haven't configured that anywhere...

Any ideas nowHave I missed a stepThe only configuration I have performed is in the Web.config.
3/22/2005 6:32:39 AM
Gravatar
Total Posts 18444

Re: Help with evaluating mojoPortal

Ahh, you're working with the source files. The reason you are getting that error is because the last time I committed, I think I had it configured to use the MS SQL data layer. I change it back and forth depending on what I'm working on at the moment. In the Business project, remove the reference to MSSQLData and add a project reference to MySQL data, then do Rebuild Solution and deploy. That should take of it, let me know if not.
3/22/2005 6:45:39 AM
Gravatar
Total Posts 92

Re: Help with evaluating mojoPortal

The mojoportal.Business assembly already had a reference to the MySQLData assembly.

I'm missing one crucial step I'm sure.   Was I correct in commenting out the connection keys with the exception of the MySql key?  Is there any info I can give you that will help?

3/22/2005 6:49:27 AM
Gravatar
Total Posts 92

Re: Help with evaluating mojoPortal

Here are all the mono components that I have installed that are related to mono if it helps.

libpixman-0.1.2-1.novell.9.1.i386.rpm
libpixman-devel-0.1.2-1.novell.9.1.i386.rpm
libtiff-3.5.7-22.fc2.i386.rpm
libungif_4.1.0-17.1_i386.rpm
cairo-0.3.0-0.novell.9.1.i386.rpm
libicu26-2.6.2-1.ximian.11.0.i386.rpm
mono-core-1.0.6-1.novell.9.1.i386.rpm
libgdiplus-1.0.5-1.novell.9.1.i386.rpm
mono-devel-1.0.6-1.novell.9.1.i386.rpm
mono-web-1.0.6-1.novell.9.1.i386.rpm
mono-winforms-1.0.6-1.novell.9.1.i386.rpm
mono-data-1.0.6-1.novell.9.1.i386.rpm
bytefx-data-mysql-1.0.6-1.novell.9.1.i386.rpm
mono-data-postgresql-1.0.6-1.novell.9.1.i386.rpm
mono-extras-1.0.6-1.novell.9.1.i386.rpm
xsp-1.0.6-1.novell.9.1.i386.rpm
mod_mono-1.0.6-1.novell.9.1.i386.rpm


3/22/2005 7:04:11 AM
Gravatar
Total Posts 18444

Re: Help with evaluating mojoPortal

Ok, if its using the right data layer I suspect  a data problem. Check the mp_Sites table and mp_Pages table and make sure they are populated. There should be 1 row in mp_Sites and several rows in mp_Pages.

The error makes me think its not creating a SiteSettings object which is what the MasterPages uses to know what skin to use. The missing data is the most likely cause.

3/22/2005 7:08:00 AM
Gravatar
Total Posts 92

Re: Help with evaluating mojoPortal

I gotta mention that you give better tech support than most products we actually have to pay for service...

It looks like the tables are populated.? I don't remember any errors running the sql's.
3/22/2005 7:21:23 AM
Gravatar
Total Posts 18444

Re: Help with evaluating mojoPortal

The data looks right so my next line of thinking is whether the user can connect from the host. MySQL is very granular about who can connect and from what machine. If the db is on the same server as the web try using root with a blank password in the connection string. If not on the same machine, do you have a MySQL client on a remote machine that you can use to try and connect from using the mojo user?

Also make sure MySQL is configured to accept tcp/ip connections, you may need to refer to the MySQL documentation for that.

Other than that I can say I have never tested with mono 1.0.6, my understanding is the 1.1.4 branch is now considered the most stable. You might try deploying  the release files instead of the compiled sources and see if that makes any difference, though it really shouldn't. If you continue getting errors is it possible for you to un-install mono and install the 1.1.4 branch?

I try to be responsive on support, whether I can actualy help you is yet to be seen

3/22/2005 7:43:16 AM
Gravatar
Total Posts 92

Re: Help with evaluating mojoPortal

Okay, just to be sure I logged into my testbed at home where I'm testing mojoportal and did the following on the mysql server.

GRANT ALL ON mojoportal.* TO mojo@'%' IDENTIFIED BY "mojo";
flush privileges;

Verified that port 3306 was open on my firewall.

Then on my office's second gateway connected to mojoportal on computerlogix.net as mojo.

[richardb@gateway2-w richardb]$ mysql -u mojo -h computerlogix.net -pmojo
Welcome to the MySQL monitor.? Commands end with ; or g.
Your MySQL connection id is 362 to server version: 4.1.8-standard

Type 'help;' or 'h' for help. Type 'c' to clear the buffer.

mysql> use mojoportal;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed

I installed mono 1.06 because all the components were available by rpm for Fedora Core 2.? The newer versions were missing components and the rpm's wouldn't install because of pre-requisites.? (I formatted the server since then)

I was trying to run a quick demo to show management that we can modify to our company's needs, and having experience with csharp I want to run something like yours.? I really don't want to use php or god forbid asp.net running on IIS.(I administrate 11 servers, and the only ones that give me trouble are the 4 windows servers)

Oh well. I'll try an upgrade of mono and see what happens.Depends on how much time I have.
3/22/2005 7:52:40 AM
Gravatar
Total Posts 18444

Re: Help with evaluating mojoPortal

Another possible culprit is the version of MySQL. Seems like I read about some issues with the ByteFX provider and a specific version of MySQL maybe 4.1.8

Do you have  machine where you could install a newer version of MySQL and give that a try? Maybe install it on your windows machine and then try to hit it from the Fedora web server.

I'll keep pondering on my end and post back if I think of anything else.

You must sign in to post in the forums. This thread is closed to new posts.