Skins acting differently on forums

A place for discussion about skinning and design. Before posting questions here you should review the documentation about creating skins.

This thread is closed to new posts. You must sign in to post in the forums.
7/6/2010 5:57:56 AM
Gravatar
Total Posts 17

Skins acting differently on forums

(Another annoying question from me!)

Hello!

I've been using a few different skins across the site I'm building and they all work fine on forum pages, (when the URL contains /forums/ForumView.aspx).

The main navigation doesn't sit with the wrapcenter div as it does on other pages, but I can't see anything in the forum css that is adding or altering any existing positioning. Also in IE5 and 6 it moves a lot of stuff around and even cuts off the top half of my navigation links.

Has anyone else experienced similar problems or can think of what might be causing it? Like I said, the skin does work fine on all other pages it's applied to.

Thanks,

Andy

7/19/2010 7:31:18 AM
Gravatar
Total Posts 17

Re: Skins acting differently on forums

Hello again,

Just noticed the same is happening on all the admin pages and settings pages. Does this shed any light on it for anyone?

Thanks,

Andy

7/19/2010 8:35:06 AM
Gravatar
Total Posts 2188

Re: Skins acting differently on forums

Hi Andy,

Can you provide some screenshots by chance?

Thanks,
Joe D.

7/19/2010 9:18:47 AM
Gravatar
Total Posts 17

Re: Skins acting differently on forums

Hi Joe,

I've uploaded to screenshots to photobucket. Both show the primary navigation falling to 2 lines at 800x600 resolution (which is fine) but the problem occurs when the content overlaps the navigation.

Working

Not working

Thanks,

Andy

7/19/2010 10:29:27 AM
Gravatar
Total Posts 2188

Re: Skins acting differently on forums

Hi Andy,

That is the breadcrumb control. Find the .breadcrumbs selector in your CSS and add "clear:both;" to it (without quotes of course).

HTH,
Joe D.

7/20/2010 5:43:20 AM
Gravatar
Total Posts 17

Re: Skins acting differently on forums

Hi Joe,

Thanks for the suggestion. Unfortunately it's still not working correctly :( Any ideas?

Andy

7/20/2010 8:44:59 AM
Gravatar
Total Posts 2188

Re: Skins acting differently on forums

Hi Andy,

Without being able to see the CSS that you are using, I can't help much more. The breadcrumb class is most likely the place you need to look.

Give FireBug a try. Using it, you can see what CSS is being applied and then you should be able to find a solution.

HTH,
Joe D.

You must sign in to post in the forums. This thread is closed to new posts.