Error 403 for one user only

This forum is primarily for reporting issues about Web Accessibility such as difficulty using mojoPortal with a screen reader or other assistive technology.

Post any feedback here related to improving the accessibility or usability of mojoPortal. As stated in our Accessibility documentation, it is an important goal of the project that both the front-end customer experience and the back end administration and content publishing features be accessible to as many people as possible. Ideally, if you post about problems, we will also be glad to have suggestions on how the problems can be fixed but all constructive feedback on these issues is welcome.

This thread is closed to new posts. You must sign in to post in the forums.
6/24/2010 4:37:45 PM
Gravatar
Total Posts 11

Error 403 for one user only

I am using mojoPortal for our internal intranet site.  All users can browse the site except one who is getting a 403 Forbidden error on the directory or page.  They have the problem when browsing with both FireFox and IE.  User had no problems before today.  He actually logged in today for a few minutes before the 403 started coming  up.  Looking at the IIS logs, the sc-status is 403, the sc-substatus and sc-win32-status are both 0.  For this user only.

mojoPortal is installed on a Win2008/IIS 7 machine.  I have checked browser settings, server settings, etc.  All appear to be OK.  Anybody have any ideas of what to look for?

6/24/2010 4:50:08 PM
Gravatar
Total Posts 69

Re: Error 403 for one user only

Find out the user's ip address and see if it is listed in Administration > Advanced Tools > Banned IP Addresses

6/24/2010 5:14:59 PM
Gravatar
Total Posts 11

Re: Error 403 for one user only

Yes, it gives a PathTooLongException, what does that mean?

6/24/2010 5:44:27 PM
Gravatar
Total Posts 11

Re: Error 403 for one user only

Steve,

 

Thank you for pointing me in the right direction.  Here is exactly what happened:

The user maintains a "Daily Quote" forum where he posts a new daily quote every day.  He consistently used the same title on every posting "Daily Quote."  mojoPortal creates an ASPX url based on the title.  If the page name has been used before, a 1 is preppended until a unique url has been created.  The daily quotes have been going for almost 2 years so the url became something like 111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111daily-quote.aspx

which is too big for the system to handle.  The IP is banned at this point and the user gets a 403 Forbidden error for all sites created within mojoPortal.

 

I am using a little older version of mojoPortal, so I don't know if this has been fixed.  I am using version 2.3.1.3 MSSQL.

6/24/2010 6:14:39 PM
Gravatar
Total Posts 69

Re: Error 403 for one user only

I don't think it auto bans ip addresses for path too long exception in the latest version of mojoPortal, but you can disable it by commenting out the BannedIPBlockingModule from the modules section of Web.config. But the user may still get an error if the url is too long.

I think the bug about adding 1s to make the url unique was also fixed a while back, now it increments numbers I think.

That is a pretty old version, if you decide to upgrade from a version that old you should read all the release notes from your current version to the new one before hand and be sure to backup both the site and the db so you could restore it if anything goes wrong.

You must sign in to post in the forums. This thread is closed to new posts.