Logo not available after changes to Layout.Master & style.css

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
6/4/2010 4:29:41 PM
Gravatar
Total Posts 383
Thanks Squire Dude

Logo not available after changes to Layout.Master & style.css

I would like to have a logo on the header of each page.  I am using the StyleShout_Techmaia style, I have changed the files in Data/Sites/1/skins/styleshout-techmania/ to no avail.

I have followed the directions on the Documentation page (http://www.mojoportal.com/whereisthesitelogo.aspx ) but I still do not see anything in the Admin page or the site.

Am I missing something?

6/4/2010 4:37:00 PM
Gravatar
Total Posts 383
Thanks Squire Dude

Re: Logo not available after changes to Layout.Master & style.css

Okay I had to refresh the site several times and now the Logo list box shows up in the Site Settings page... so far the logo does NOT show up on any page.

6/4/2010 9:29:54 PM
Gravatar
Total Posts 2188

Re: Logo not available after changes to Layout.Master & style.css

Hi,

Make sure you have the following keys set in your user.config and then clear your browser cache.

<add key="CacheCssOnServer" value="false" />
<add key="CacheCssInBrowser" value="false" />

After adding these to your user.config; open the web.config, add a space to the bottom and then save it. This will cause the Application Pool to recycle and load the settings from the user.config.

Once you are finished making skin changes, change these to True.

HTH,
Joe D.

6/4/2010 11:11:45 PM
Gravatar
Total Posts 383
Thanks Squire Dude

Re: Logo not available after changes to Layout.Master & style.css

Hi Joe,

I have made all the changes etc that you suggest.  I have one question not being a CSS person... What changes?   Your wrote "Once you are finished making skin changes, change these to True."

6/5/2010 10:39:51 AM
Gravatar
Total Posts 2188

Re: Logo not available after changes to Layout.Master & style.css

Hi,

I meant that after you are finished making any changes to any of the files inside your skin directory, change those keys to True.

Thanks,
Joe D.

6/5/2010 11:00:27 AM
Gravatar
Total Posts 18439

Re: Logo not available after changes to Layout.Master & style.css

Hi,

To use the SiteLogo, you must have the SiteLogo control in the layout.master file of your skin:

<portal:SiteLogo id="SiteLogo" runat="server"></portal:SiteLogo>

Many of the skins do not use it and therefore do not have it in layout.master, if you are converting a skin that did not use it to now use it, then you need to add this.

Hope it helps,

Joe

6/6/2010 11:45:57 AM
Gravatar
Total Posts 383
Thanks Squire Dude

Re: Logo not available after changes to Layout.Master & style.css

Hi Joe,

Thanks a lot you have been a great help in getting my logo on the site.  Of course after inserting it into the page I found out that where it was before it worked but with this color combination etc... it sucks big time~!  So its back to the drawing board to modify it to work with the site... gotta figure out transparancy etc.

But you have been a huge help, thanks again.

SquireDude

You must sign in to post in the forums. This thread is closed to new posts.