Install error cannot connect to mssql

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
3/24/2010 1:34:26 PM
Gravatar
Total Posts 6

Install error cannot connect to mssql

Just started to test MoJoPortal, and of course hit the wall 2 minutes in.

System is Windows Server 2003 R2 SP2, IIS 6, .Net 3.5 sp1, MS SQL 2005 Developer in mixed mode, remote connections = true, named pipes & TCP IP enabled, DB user is sysadmin, file system permission = OK, and the server does run DotNetNuke. Seems like all should be OK.

I load /setup/default.aspx and receive the error 'the system cannot connect to the mssql database.....', not accessible.....named pipes error 40.

Anyone have any thoughts ?

 

Thanks in advance

 

 

3/24/2010 2:05:02 PM
Gravatar
Total Posts 1992

Re: Install error cannot connect to mssql

Hello,

What does your SQL connection string in your user.config file look like?

It should look similar to the following:

<add key="MSSQLConnectionString" value="server=(local);UID=sysadmin;PWD=Mojo123$$;database=mojoDB" />

HTH,
Joe D.

3/24/2010 4:49:19 PM
Gravatar
Total Posts 6

Re: Install error cannot connect to mssql

Joe,

 

Hi. Yeah, the string is the same.

That's what confuses me. While we never setup MoJoPortal we are a database company and use some .net and Coldfusion all the time.

FWIW I have added new users with full permissions, used (local), the instance name, and even the IP address. Checked all the configs listed in the doc files here and they look right.

Thanks

Ted

3/24/2010 5:56:24 PM
Gravatar
Total Posts 18444

Re: Install error cannot connect to mssql

Hi Ted,

Does a user.config file exist in the root of your web folder?

Are you setting the connection string in Web.config or user.config?

If user.config is present, settings there will trump Web.config

If you make a change in user.config it will not be detected by the runtime, so you have to touch web.config to make it load your new settings.

Make sure you are using the connection string in the <appSettings section not the <ConnectionStrings section

If you have DNN working on the same machine can you post the connection string for that but mask the user id and password?

Hope it helps,

Joe

3/26/2010 10:10:53 AM
Gravatar
Total Posts 6

Re: Install error cannot connect to mssql

Hi,

Sorry I didn't get back sooner guys, the old billable work thing. Both of you helped a lot, thanks.

The short story is I had entered my DB name incorrectly the first time, and then just kept fixing things. Of course I never updated web.config, just user.

This AM a light went off.................updated user.config, inserted a new line in web.config, and you know the rest.

I have not even logged in yet to look around.

Thanks to both of you for your help. If we do use MoJo and get any good at it I'll return the favor to others on the forum, that's the way it works :-)

 

Ted

You must sign in to post in the forums. This thread is closed to new posts.