Configuration error in web.config when installing on ISS 6

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
1/27/2010 2:26:50 PM
Gravatar
Total Posts 76

Configuration error in web.config when installing on ISS 6

Hello,

i wanna install mojoportal on my windows server 2003 system with ISS 6.
I downloaded the latest mojoportal package. Did everything as written down in the tutorial. Also set write permission to the /data folder.

But i get folowing error:

Server Error in '/' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized attribute 'type'.

Source Error:


Line 5: <section name="neatUpload" type="Brettle.Web.NeatUpload.ConfigSectionHandler, Brettle.Web.NeatUpload" allowLocation="true" />
Line 6: <sectionGroup name="system.web"></sectionGroup>
Line 7: <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
Line 8: <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
Line 9: <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
 

Source File: d:\inetpub\wwwroot\web.config Line: 7


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2379; ASP.NET Version:1.1.4322.2379

 

What can this be???

Thnx

1/27/2010 2:36:53 PM
Gravatar
Total Posts 2187

Re: Configuration error in web.config when installing on ISS 6

Hello,

Your website is set to use .NET 1.1. It should be set to use .NET 2.0. If you have access to IIS Manager on the server, you can change this by opening the Website Properties, selecting the .NET tab and then selecting the correction version. If you do not have access to IIS Manager, you will have to have access to a control panel provided by your host or your host will have to change it for you.

Also, .NET 3.5 SP1 should be installed on your server as described in the hosting requirements.

HTH,
Joe D.

1/28/2010 5:51:34 AM
Gravatar
Total Posts 76

Re: Configuration error in web.config when installing on ISS 6

Sorry for the late reply.

It helped! I changed it to asp.net 2.0.

THNX!

You must sign in to post in the forums. This thread is closed to new posts.