Strange Behaviour for mono users

mojoPortal is no longer supported on mono. This forum is here for archival purposes.

This forum is for any topic related to running mojoPortal on GNU/Linux or Mac using Mono.

Anyone who can help with testing mojoPortal 2.x on Linux with Mono to find the bugs and report to the Mono team, this will help a lot. See the instructions for building with MonoDevelop.

This thread is closed to new posts. You must sign in to post in the forums.
11/25/2009 7:32:05 AM
Gravatar
Total Posts 8

Strange Behaviour for mono users

Mono 2.4.2.3 (compiled way)

Apache 2.2.14 (compiled way)

MySQL 5.0.51a

MojoPortal 2-3-1-9

Debian Lenny

 

Hi,

A strange behaviour for mono.

When you connect here : http://www.maisonpedia.com/contact.aspx

You should see writen in red in the bottom "Incorrect, try again"

(Or for french people "Incorrect, veuillez recommencer")

It look like you have already push enter.

We have inserted a search engine application in mojoportal and the same behaviour occur.

We have done an upgrade to 2-3-3-0 and we have seen a bug in friendly URL For this reason we have made a roolback to 2-3-1-9 version of MojoPortal

There no emergency to solve this problem... We can live with this ;)

And for information this is the only difference between .NET and Mono for our utilisation of MojoPortal :)

Many Thanks

 

11/25/2009 9:45:17 AM
Gravatar
Total Posts 18444

Re: Strange Behaviour for mono users

It looks like some difference in rendering on Mono so I guess it's a Mono bug.

On my contact form on Windows it renders like this:

<span id="ctl01_mainContent_ctl01_captcha52" style="display:inline-block;color:Red;height:50px;width:180px;display:none;">Incorrect, try again</span>

but on your site running on Mono the styles are reversed like this:

<span id="ctl00_mainContent_ctl00_captcha5" style="display:none;display:inline-block;color:Red;height:50px;width:180px;">Incorrect, try again</span>

since display:inline-block; comes after display:none; it does display on Mono whereas on windows the display:none; comes after display:inline-block; so it does not display the text until validation fails and it changes the style.

You could try using one of the other captchas. You can use ReCaptha (requires an account) or  the Simple Math Captcha. Yiou can choose it from Administration > Site Settings > Security > Anti Spam.

Best,

Joe

11/27/2009 1:11:51 PM
Gravatar
Total Posts 8

Re: Strange Behaviour for mono users

Hi Joe,

 

You are absolutly right concernig the rendering

We will try to understand what's wrong and where because the application we have added in mojoportal has the same problem.

And this application is OK when it's in stand alone mono linux environment. You can see here (search engine concerning artists)

We will try to find the solution and we will inform you if we see something...

 

Thank you Joe

Pierre-Alain

You must sign in to post in the forums. This thread is closed to new posts.