ASP.NET user missing

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
11/24/2009 2:32:09 PM
Gravatar
Total Posts 33

ASP.NET user missing

Hello!

Try to install MojoPortal on Windows 2008 R2 but I get error on the Data folder. The ASP user dont have write access - but I cant find any ASP.NETR user on local users on the machine?

11/24/2009 2:45:07 PM
Gravatar
Total Posts 2186

Re: ASP.NET user missing

The ASP.NET user is both a user account and a term to identify the user account assigned to the application pool your website uses. You will not find a user named ASP.NET in 2008 R2 unless someone creates it manually and then it will not be a special account anyway (it used to be a default account created when .NET was installed but it hasn't been for a while now). To find out which user account on your machine is assigned to the application pool your site is using, open IIS manager, find your site and select it, click the Basic Settings link in the Actions pane, make note of the application pool name. Now go to Application Pools (it is under the server name directly above the Sites in IIS). Find the application pool with the name you noted and make a note of the Identity. The final step is to make sure the Identity of the App pool has write permissions to the /Data and /App_Data directories.

HTH,
Joe

11/24/2009 2:54:19 PM
Gravatar
Total Posts 18439

Re: ASP.NET user missing

By default its going to be Network Service user on Win 2008

11/24/2009 2:56:11 PM
Gravatar
Total Posts 33

Re: ASP.NET user missing

Thanks!

The poolname is Mojo1
In the "Identity" it stands "ApplicationPoolIdentity" - but I cant find that name and give it rights to a directory??

11/24/2009 2:58:57 PM
Gravatar
Total Posts 33

Re: ASP.NET user missing

I have given network service full rights as well :(

11/24/2009 2:59:04 PM
Gravatar
Total Posts 2186

Re: ASP.NET user missing

Right-Click on the application pool and select Advanced Settings. The Identity should be listed in the Process Model section.

-Joe D

11/24/2009 3:03:16 PM
Gravatar
Total Posts 33

Re: ASP.NET user missing

The name there was "ApplicationPoolIdentity" and that could´nt be found in the security settings.

I changed that to "Network service" and now it runs :)

Thanks

You must sign in to post in the forums. This thread is closed to new posts.