Addnew Survey problem

This is an open forum for any mojoPortal topics that don't fall into the other categories.

This thread is closed to new posts. You must sign in to post in the forums.
11/11/2009 5:03:21 PM
Gravatar
Total Posts 85

Addnew Survey problem

Hi, upgrade new mojo version.

I tried Addnew survey, but failed. (OS MS Windows 7 on Internetexplorer 8.0  and  On my Iphone Safari Explorer)

- Selected "Choose Active Survey" and open new windows and "no record founds" messege ok.

- Selected "Addnew Survey" and open two editor ,  i 'm wrote Survey name and wrote in editor... but few second i see error IE left side (! Done).

- Select Save button. but dont create new survey.

IE Error detail ;

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.1; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)

Timestamp: Wed, 11 Nov 2009 22:46:09 UTC

Message: Object doesn't support this action

Line: 97

Char: 1548

Code: 0

URI: http://www.abapspecialist.com/ClientScript/fckeditor265/editor/js/fckeditorcode_ie.js

Best,

Volkan PEKGOZEGU

12/21/2009 2:13:52 PM
Gravatar
Total Posts 85

Re: Addnew Survey problem

Hi,

I tried Addnew survey, but failed. (OS MS Windows 7 on Internetexplorer 8.0 and On my Iphone Safari Explorer)

- Selected "Choose Active Survey" and open new windows and "no record founds" messege ok.
- Selected "Addnew Survey" and open two editor , i 'm wrote Survey name and wrote in editor...
- Select Save button. but dont create new survey...

 

My Mojo Version 2.3.3.0, MsSQL Database...

Best,

Volkan PEKGOZEGU

www.abapspecialist.com
 

12/21/2009 2:28:11 PM
Gravatar
Total Posts 18439

Re: Addnew Survey problem

Hi Volkan,

Can you try it on demo.mojoportal.com?

Do you get the same result?

Does it only happen with iphone, can you try Firefox and see if you get the same result on your site?

Best,

Joe

12/21/2009 3:13:32 PM
Gravatar
Total Posts 85

Re: Addnew Survey problem

Hi Joe,

I tried on demo.mojoportal.com but result same. I can't do it. (IE explorer 8.0 do not any message error)

 

Best,

Volkan PEKGOZEGU

www.abapspecialist.com

 

12/28/2009 1:57:40 PM
Gravatar
Total Posts 85

Re: Addnew Survey problem

guess think unsolved... :(  or How to create a survey or I do not understand how to create

 

Best,

Volkan PEKGOZEGU

www.abapdanismani.com

www.abapspecialist.com

12/29/2009 10:55:48 AM
Gravatar
Total Posts 2187

Re: Addnew Survey problem

Hi Volkan,

I have added multiple surveys and pages to surveys using IE8/FF/IE7. Can you give step by step details of what you are doing and received error messages or issues you are having?

Thanks,
Joe D.

12/29/2009 10:57:32 AM
Gravatar
Total Posts 18439

Re: Addnew Survey problem

Hi Volkan,

When I test on demo.mojoportal.com using IE 8 on Windows 7 it works fine for me. After you create the survey you need to add pages to it and add questions to pages and then make it the active survey for it to appear on the page.

It would not surprise me if there are issues editing a survey with iphone, however I'm unable to test that scenario right now, I dropped my iphone into a glass of water last week :-(

Best,

Joe

12/29/2009 12:02:42 PM
Gravatar
Total Posts 2187

Re: Addnew Survey problem

Hey guys,

I just tested creating a new page, survey feature instance, survey, survey page and survey question using an iPod Touch and it worked fine. I also activated the survey and completed it as a user would. See http://demo.mojoportal.com.

So we know that the Survey feature works as designed using the iPod/iPhone browser.

Thanks,
Joe D.

12/29/2009 1:21:42 PM
Gravatar
Total Posts 85

Re: Addnew Survey problem

   Hi Joe Audette ,version and google translate primarily 2.3.3.2 Thank you very much. They are perfect :)

   Hi Joe Dayvis & Joe Audette , yes i sow your test survey a short time ago on demomojo, i created survey on demomojo site and fine work on windows 7... your opiniyon why i can not create previously ?  I do not get an error..

   i am trying to create a survey step by step how I am writing. ;  (Windows 7 IE 8.0 )

   - Login admin user

   - Select Content Manager

   - select Survey Content ( After Select i see this text   survey  Setting  Choose Survey  )

                                                                                             No survey selected

 

   - Select Choose Survey ( After Select i see text     Surveys   )

                                                                            Add New Survey

 

  - Select Add New Survey

  - i write Survey Name = Test , Welcome text = Test, Survey Completed Text = Test

  - Select Save button and return previously page and dont create any Survey.. After Save button i see Choose Survey page and  

                                                                                                                                                                           Surveys

                                                                                                                                                                    Add New Survey           
 

  I tried last week on demo.mojoportal.com but did not change result. I can't do it.. So but i tried now on demo.mojoportal.com and successful, i can do it.  Not getting any error.

But i can not create on my own site. what is your opinion about this problem.i could not create on the website at demomojo last week. But today I've created in demomojo site. What am I doing wrong?

 i will be happy if you can help me.

Best Regards,

Volkan PEKGOZEGU

www.abapspecialist.com

 
 

12/29/2009 1:32:21 PM
Gravatar
Total Posts 18439

Re: Addnew Survey problem

Hi Volkan,

I suspect the problem is this feature is not really designed for working in the context of Content Manager, it needs to be used in the context of a a specific page.

Steps that will work.

  1. Create a page where you want to put a survey
  2. Go to "Edit This Page"
  3. Choose Survey from the dropdown and choose a name for the feature instance and click the button to add it to the page.
  4. view the page
  5. click "Choose Survey"
  6. proceed as you expect it should work

Hope it helps,

Joe

12/29/2009 2:11:43 PM
Gravatar
Total Posts 85

Re: Addnew Survey problem

Heyyyy, yeah, i m happy, i tried and I create now, succesfull :)... ( I Understand what is My fault.  I have not do it "1.Create a page where you want to put a survey" )...

 

Thankyou for help me,

 

Best,

Volkan PEKGOZEGU

www.abapspecialist.com

You must sign in to post in the forums. This thread is closed to new posts.