Friendly URL enabling?

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
3/19/2006 4:24:00 PM
Gravatar
Total Posts 8

Friendly URL enabling?

I'm failing to find how to enable the friendly url option, can anyone shed some light on this? I want to interlink pages within my site and the friendly url seems to be a good way to do it.
3/20/2006 2:51:07 AM
Gravatar
Total Posts 18444

Re: Friendly URL enabling?

Hi Jae,

I plan to add some documentation on that soon. I also plan to make it create friendly urls by default but have not had a chance to implement it yet.

Here is how you can do it.
first go to your Url Manager and create the friendly url for tha page you are interested in. For example the forums page of this site has a real url:
http://www.mojoportal.com/Default.aspx?pageindex=3&pageid=5
which is mapped by a friendly url:
http://www.mojoportal.com/forums.aspx

verify that the friendly url works then click the gear icon to get to page settings. Check the box that says useUrl and enter the friendly url. When this site was running on mono I had fully qualified urls for the friendly urls but in moving to 2.0 .NET I found some issues with site map provider and now I enter my url in page settings like this:
~/forums.aspx instead of fully qualified
http://www.mojoportal.com/forums.aspx

note that I do not use the ~ in the UrlManager just in page settings url setting

on mono if you have mono set as the handler for the whole directory, the .aspx extension is not required for friendly urls but on windows it is.

Hope it helps,

Joe
3/20/2006 2:25:21 PM
Gravatar
Total Posts 8

Re: Friendly URL enabling?

Thanks Joe...I was missing the ~/ prefix. It kept trying to put it under Control.

One thing if noticed is that if I have the "show child menu" option on with the URL enabled...the show child menu does not work. However, if I kill the url option the menu does show up.

You mentioned that you were going to implement friendly urls in the future, is there a way I can make what I do now compatible with your change?

Thanks again.
3/20/2006 4:25:25 PM
Gravatar
Total Posts 18444

Re: Friendly URL enabling?

Yeah that ChildPageMenu thing is a mono bug thats been there for quite a while. Its hard to get a small use case that reproduces the problem so its hard to report a bug and get it fixed. It works fine on Windows.

Friendly Urls is already implemented what I'm going to add is when you create a page it will default to check the box to use url and with a little javascript I will default the url to the pagename with no spaces .aspx

With the Url Manager you can create more than one friendly mapping to a page but what I plan to add is just to make a friendly url by default and use it.


Cheers,

Joe
You must sign in to post in the forums. This thread is closed to new posts.