when i do /Setup/Default.aspx

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
3/20/2009 2:26:46 PM
Gravatar
Total Posts 1

when i do /Setup/Default.aspx

<%@ Page Language="C#" AutoEventWireup="false" EnableSessionState="False" CodeBehind="Default.aspx.cs" Inherits="mojoPortal.Web.UI.Pages.SetupHome" %>
 

3/25/2009 7:58:39 PM
Gravatar
Total Posts 2183

Re: when i do /Setup/Default.aspx

Hello, I would like to help you but I don't have enough information. Please respond with the following info.

  • What operating system?
  • What database platform?
  • What version of mojoPortal?

 

3/31/2009 10:41:30 AM
Gravatar
Total Posts 3

Re: when i do /Setup/Default.aspx

Hi,

i have a problem as well, when i do/setup/default.aspx

Parser Error Message: Unrecognized configuration section 'xhtmlConformance'

Source Error:

Line 578:
Line 579: -->
Line 580: <xhtmlConformance mode="Strict" />
Line 581: <!--

--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573

my OS : XP

my DB : msSQL

mojo version : newest

 

please anyone help me :-)

thanks

3/31/2009 10:46:25 AM
Gravatar
Total Posts 18439

Re: when i do /Setup/Default.aspx

Your site is configured for 1.1 .NET as your error shows

Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573 

You need to install .NET 3.5 SP1 and configure your site to use it.

Hope it helps,

Joe

4/1/2009 9:35:47 PM
Gravatar
Total Posts 2

Re: when i do /Setup/Default.aspx

Hi fellow mojoPortal people,

I'm evaluating mojoPortal and need just a little help getting my installation up and running.  Here's what I'm running along with my setup errors-

  • OS: XP w/ SP3
  • Database: MS Sql Server 2005
  • mojoPortal: think it's rev. 4935 (downloaded it from svn trunk 3/30)

Here's my setup errors.  It looks like the setup script can't find a sql procedure {..Invalid object name 'dbo.mp_BlogCategories_SelectByModule'..}

Probing system...
File system permissions ok.
MSSQL database connection ok.
database permissions are sufficient to alter schema.
database initial schema needs to be created.
Running script mojoportal-core - 2.2.7.8 - 00:00:02.2656250
Running script mojoportal-core - 2.2.7.9 - 00:00:28.5781250
Running script mojoportal-core - 2.2.8.0 - 00:00:28.6875000
Running script mojoportal-core - 2.2.8.1 - 00:00:28.7187500
Running script mojoportal-core - 2.2.8.2 - 00:00:28.7343750
Running script mojoportal-core - 2.2.8.3 - 00:00:28.7812500
Running script mojoportal-core - 2.2.8.4 - 00:00:28.8125000
Running script mojoportal-core - 2.2.8.5 - 00:00:28.9375000
Running script mojoportal-core - 2.2.8.6 - 00:00:28.9531250
Running script mojoportal-core - 2.2.8.7 - 00:00:28.9843750
Running script mojoportal-core - 2.2.8.8 - 00:00:29.0312500
Running script mojoportal-core - 2.2.8.9 - 00:00:29.0781250
Running script mojoportal-core - 2.2.9.0 - 00:00:29.2031250
Running script mojoportal-core - 2.2.9.1 - 00:00:29.2812500
Running script mojoportal-core - 2.2.9.2 - 00:00:29.3125000
Running script mojoportal-core - 2.2.9.3 - 00:00:29.4062500
Running script mojoportal-core - 2.2.9.4 - 00:00:29.4375000
Running script mojoportal-core - 2.2.9.5 - 00:00:29.5000000
Running script mojoportal-core - 2.2.9.6 - 00:00:29.5781250
Running script mojoportal-core - 2.2.9.7 - 00:00:29.5937500
Running script mojoportal-core - 2.2.9.8 - 00:00:29.6562500
System.Data.SqlClient.SqlException: Invalid object name 'dbo.mp_BlogCategories_SelectByModule'. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at mojoPortal.Data.SqlHelper.ExecuteNonQuery(SqlTransaction transaction, CommandType commandType, String commandText, SqlParameter[] commandParameters) in C:\Documents and Settings\csharp\My Documents\Visual Studio 2008\Projects\mojoportal\mojoPortal.Data.MSSQL\SQLHelper.cs:line 448 at mojoPortal.Data.DBPortal.DatabaseHelperRunScript(String script, String overrideConnectionInfo) in C:\Documents and Settings\csharp\My Documents\Visual Studio 2008\Projects\mojoportal\mojoPortal.Data.MSSQL\dbPortal.cs:line 571 at mojoPortal.Data.DBPortal.DatabaseHelperRunScript(FileInfo scriptFile, String overrideConnectionInfo) in C:\Documents and Settings\csharp\My Documents\Visual Studio 2008\Projects\mojoportal\mojoPortal.Data.MSSQL\dbPortal.cs:line 507 at mojoPortal.Business.DatabaseHelper.RunScript(Guid applicationId, FileInfo scriptFile, String overrideConnectionInfo) in C:\Documents and Settings\csharp\My Documents\Visual Studio 2008\Projects\mojoportal\mojoPortal.Business\DatabaseHelper.cs:line 299 - 00:00:29.8281250
Note: This page shows some information that is helpful during setup and upgrades but for security it would be best not to show any information when the system is up to date. You can disable setup and suppress all information on this page by setting DisableSetup=true in Web.config. When you need to upgrade, you can set this back to false. If you are logged in as Administrator setup will run and you will be able to see this page even if it is disabled in Web.config so you can easily leave it disabled and just login before upgrading. But if you are not logged in you will need to enable setup in Web.config.
 

Thanks for your help.

Sasha

4/2/2009 6:26:14 AM
Gravatar
Total Posts 18439

Re: when i do /Setup/Default.aspx

Hi Sasha,

This was a bug in the svn version. Its fixed if you do svn update. The problem was that I accidently put an upgrade script for the blog into the core upgrade script.  This caused an error because the main blog installation scripts don't run until after the core installation.

Right click the root folder and do SVN Update, then rebuild the solution then visit /Setup/Default.aspx again.

Thanks,

Joe

4/2/2009 8:50:43 AM
Gravatar
Total Posts 3

Re: when i do /Setup/Default.aspx

Hi Joe

after install .net 3.5 SP1  

the installation is workSmile

thanks Joe

4/2/2009 7:09:46 PM
Gravatar
Total Posts 2

Re: when i do /Setup/Default.aspx

Hi Joe,

I got the latest using svn update, recompiled, and visited the setup/default.aspx page.  It installed successfully.

Thank you very much!

Sasha

You must sign in to post in the forums. This thread is closed to new posts.