couldn't sign in to my test mojoportal website

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
3/6/2009 10:52:01 AM
Gravatar
Total Posts 2

couldn't sign in to my test mojoportal website

Hi there

I did (hopefully) everything that was described in installation instruction tin order to install mojoportal on remote server. Instalation script started and in a moment I've gotten an error message:

An Error Occurred:The type initializer for
'mojoPortal.Web.Framework.CryptoHelper' threw an exception.
Source:mojoPortal.Web.Framework
Stack Trace at mojoPortal.Web.Framework.CryptoHelper.Hash(String cleanText) at
mojoPortal.Web.mojoMembershipProvider.EncodePassword(String pass,
MembershipPasswordFormat passwordFormat) at
mojoPortal.Web.mojoMembershipProvider.EncodePassword(String pass, SiteSettings
site) at mojoPortal.Web.mojoSetup.CreateRequiredRolesAndAdminUser(SiteSettings
site) at mojoPortal.Web.UI.Pages.SetupHome.CreateSiteAndAdminUser() at
mojoPortal.Web.UI.Pages.SetupHome.RunSetup() at
mojoPortal.Web.UI.Pages.SetupHome.Page_Load(Object sender, EventArgs e) at
System.Web.UI.Control.OnLoad(EventArgs e) at
System.Web.UI.Control.LoadRecursive() at
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint,
Boolean includeStagesAfterAsyncPoint)

I hit the Refresh button and than instalation was completed. I could go to my test webside but when I tried to login I've gotten a message:

We're sorry but a server error has occurred while trying to process your request. The error has been logged and will be reviewed by our staff as soon as possible. It is possible that the error was just a momentary hiccup and you may wish to use the back button and try again or go back to the home page.

Could anybody explain how to fix that? I've installed mojoportal on my local computer without any problems.

Thanks in advance for any help

Zbyszek

3/10/2009 10:12:56 AM
Gravatar
Total Posts 2183

Re: couldn't sign in to my test mojoportal website

After looking at some old posts on this forum I am led to believe this could be caused by one of the following:

  1. The server you are installing on has .NET 2.0.
  2. Read/write file permissions are set on the data directory.
  3. All files from the mojoPortal package were properly uploaded.

It might help to take a look at this post: http://www.mojoportal.com/Forums/Thread.aspx?pageid=5&mid=34&ItemID=3&thread=2186&pagenumber=1.

Hope this helps.

 

3/11/2009 9:21:47 AM
Gravatar
Total Posts 2

Re: couldn't sign in to my test mojoportal website

HI Joe

Thank you very much for your reply.

People in my hosting cimpany (resellerchoce.com) have fixed the problem for me. It was something with folder permissions and also my "mojo" root folder was not changed to application in IIS (I couldn't do it by myself because I don't have root acccess to the server).

Now I start to test my mojo portal installation. Thanks in advance for any possible help, if needed.

Zbigniew  

You must sign in to post in the forums. This thread is closed to new posts.