Error Opening Admin/SiteSetting page

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

5/18/2017 6:53:08 AM
Gravatar
Total Posts 30

Error Opening Admin/SiteSetting page

Hi! 

I have upgraded a site to version 2.5.0.0. In order to do so I cloned the site (and the DB) and installed all the new files as suggested in the Upgrading instructions . After a little struggling with the connection string. I succeed in upgrading, but I am not able to open the sitesettings page.

Here is the error message:

Any suggestion? 

Thanks in advance

Mari

Server Error in '/' Application.


Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error: 

 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace: 
 


[NullReferenceException: Object reference not set to an instance of an object.]
   mojoPortal.Web.AdminUI.SiteSettingsPage.PopulateLabels() +358
   mojoPortal.Web.AdminUI.SiteSettingsPage.Page_Load(Object sender, EventArgs e) +642
   System.Web.UI.Control.OnLoad(EventArgs e) +95
   mojoPortal.Web.mojoBasePage.OnLoad(EventArgs e) +15
   System.Web.UI.Control.LoadRecursive() +59
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +678

 


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1590.0

   

5/31/2017 8:31:31 AM
Gravatar
Total Posts 1992

Re: Error Opening Admin/SiteSetting page

Hi,

Be sure you have the correct files uploaded. Try uploading the Admin folder again.

Thanks,
Joe

10/3/2017 5:47:20 PM
Gravatar
Total Posts 1

Re: Error Opening Admin/SiteSetting page

Same here :(

10/3/2017 7:51:40 PM
Gravatar
Total Posts 1992

Re: Error Opening Admin/SiteSetting page

Be sure you have uploaded the correct files. You may want to check that the App_GlobalResources folder has been uploaded.