Starting to Debug MojoPortal Source Code

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

Please do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.

This forum is for discussing mojoPortal development

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

You can monitor commits to the repository from this page. We also recommend developers to subscribe to email notifications in the developer forum as occasionally important things are announced.

Before posting questions here you might want to review the developer documentation.

Do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.
5/18/2017 6:32:59 AM
Gravatar
Total Posts 1

Starting to Debug MojoPortal Source Code

Hi team,

I am new and when i am  starting to build MojoPortal Source code in our system it will build successfully but when i start debug the code it fetch error 

The stored procedure 'mp_SiteHosts_SelectSiteIdByHost' doesn't exist. how can i remove this and successfully run this code on my Local system. i am using visual studio 2013 and sql server 2012. please give me proper solution if it possible. thank you.

 

5/18/2017 4:59:59 PM
Gravatar
Total Posts 1981

Re: Starting to Debug MojoPortal Source Code

I suggest using Visual Studio 2015 or 2017.

The error you are getting is probably because the database hasn't been populated by setup yet. Go ahead and tell Visual Studio to continue after the error comes up and visit the /setup/default.aspx page.

Hope this helps,
Joe Davis