Not getting all the features after installing mojo portal successfully

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

Please do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.

This forum is for discussing mojoPortal development

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

You can monitor commits to the repository from this page. We also recommend developers to subscribe to email notifications in the developer forum as occasionally important things are announced.

Before posting questions here you might want to review the developer documentation.

Do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.
1/25/2017 8:10:25 AM
Gravatar
Total Posts 4

Not getting all the features after installing mojo portal successfully

Hello Joe,

I have configured mojoportal-master successfully with Visual 2015 community, after getting logged-in in my site, i have observed that only 6-7 features are available under Administration->Add/Remove feature configuration.

Before this 4-5 days back i have configured mojoportal-master and at that time by default below mentioned features were available:
ContactForm
Flickr
Image Gallery


and so on.


Right now i'm not getting all the above features after configuring any of your release version.

So, I request you to either provide me support for that or give me link of that version which provides all features by default after configuring mojoportal.

Thanks in an advance! Awaiting for your reply.

Hemang Mehta.

1/25/2017 8:16:01 AM
Gravatar
Total Posts 18444

Re: Not getting all the features after installing mojo portal successfully

make sure you rebuild the solution, then visit /Setup

there are post build events to copy files from other features into the main app, so check for build errors in case it is failing to copy files. after the files get copied they still have to be processed by the /setup page before they will appear in the UI as features that can be added to a site. Only the root master site can add features to other sites

2/1/2017 12:21:31 AM
Gravatar
Total Posts 4

Re: Not getting all the features after installing mojo portal successfully

Thanks Joe!

it helped me out. After rebuilding a solution i have got all the features.