login required to access home page

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
9/1/2015 12:51:54 AM
Gravatar
Total Posts 3

login required to access home page

I have installed one mojoPortal 2.4.0.9 instance.

When I browse the site http://localhost:8009/, it's redirected to login page. After sign in successfully, I can see home page.

If I'm an anonymous user, I can see home page by http://localhost:8009/default.aspx. But this is not convenience. I hope that any anonymous user can access home page by http://localhost:8009.

 

Windows Server 2012 Datacenter
MS SQL Server 2012
mojoPortal 2.4.0.9
.NET 4.5

 

9/1/2015 9:20:32 AM
Gravatar
Total Posts 18444

Re: login required to access home page

check page settings for the home page and make sure view roles is set as "All Users"

make sure you have Default.aspx and nothing else configured as a default document for the site in IIS

9/1/2015 8:38:31 PM
Gravatar
Total Posts 3

Re: login required to access home page

Hi Joe,

I'm pretty sure with what you said. And I even removed all default documents, and only leave Default.aspx in IIS.

Is there any configuration in mojo related to my questions? Then I can do a check.

I got these problems when I was updating the site that was built on mojoPortal 2.3.8.1. So I installed a latetest version without any modification except necessary configurations to see if there are same problems. It turned out true. 

If this is not default behaviour, then it probably has somthing to do with my IIS or server. But so far no any clue.

Thanks

9/2/2015 3:46:49 AM
Gravatar
Total Posts 3

Re: login required to access home page

I fixed it. I just move out the site from \inetpub\wwwroot\wss\VirtualDirectories\ to a new folder. 

You must sign in to post in the forums. This thread is closed to new posts.