any way to force the Google CDN to run on https ?

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

Please do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.

This forum is for discussing mojoPortal development

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

You can monitor commits to the repository from this page. We also recommend developers to subscribe to email notifications in the developer forum as occasionally important things are announced.

Before posting questions here you might want to review the developer documentation.

Do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.
This thread is closed to new posts. You must sign in to post in the forums.
8/25/2015 8:33:51 AM
Gravatar
Total Posts 48

any way to force the Google CDN to run on https ?

Hi All, 

Currently the server setting are allow to communicate with HTTPS only, so it cause the http google cdn error. 

Any way to force google cdn to run on https  ? 

thanks 

8/25/2015 9:07:09 AM
Gravatar
Total Posts 18444

Re: any way to force the Google CDN to run on https ?

in the latest version of mojoPortal you can add this in user.config then touch web.config to make it reload settings

<add key="GoogleCDNJQueryBaseUrl" value="https://ajax.googleapis.com/ajax/libs/jquery/" />

the default value is

<add key="GoogleCDNJQueryBaseUrl" value="//ajax.googleapis.com/ajax/libs/jquery/" />

which uses a protocol relative url and that normally would resolve to https if the main page is using https but with a proxy server it may not work so you need to specifically set it to use https

You must sign in to post in the forums. This thread is closed to new posts.