Contact Form Error After Upgrade

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
8/18/2015 11:10:03 AM
Gravatar
Total Posts 11

Contact Form Error After Upgrade

I just completed an upgrade from 2.4.0.4 to 2.4.0.9.  Now when navigating to our Contact Us page which loads a contact form, the user receives a generic on screen error, and the following is logged in the system log.

 

2015-08-18 10:05:06,281 ERROR 71.36.28.1 - en-US - /contact-us.aspx - mojoPortal.Web.Global -  Referrer(http://www.criadvantage.com/Default.aspx) useragent Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
System.IO.FileLoadException: Could not load file or assembly 'log4net, Version=1.2.11.0, Culture=neutral, PublicKeyToken=1b44e1d426115821' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
File name: 'log4net, Version=1.2.11.0, Culture=neutral, PublicKeyToken=1b44e1d426115821'
   at sts.FormWizard.Web.UI.FormWizardModule.Page_Load(Object sender, EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

 

I found an old support article referencing the scripts at the bottom of the Web.config file, but there are no scripts for log4net at the bottom of the Web.config file.

8/18/2015 11:14:43 AM
Gravatar
Total Posts 18444

Re: Contact Form Error After Upgrade

since you upgraded mojoportal you also need to upgrade Form Wizard Pro to the latest version to be compatible with the new version of mojoPortal

you can download the latest version of  Form Wizard Pro by clicking the "My Account" link at the top of this site and then click "Order History" and follow the link to your previous purchase of Form Wizard Pro

You must sign in to post in the forums. This thread is closed to new posts.