Add Existing Content to new page

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
11/15/2014 12:35:24 PM
Gravatar
Total Posts 55

Add Existing Content to new page

I am having trouble adding existing content to new pages.

Logged in as administrator I create a new page and upon successful page creation I click the link "Add Existing Content" next to the location drop down. This generates the standard popup window, but has the message, "Sorry you are not allowed to view this content. If you have questions about your permissions contact your site administrator."  There is no content grid listed to select content from.

 

I am the only site administrator and so I was confused. 

Things I have tried without success:

  1. Change my password
  2. Add new user to administrator role log-out then login with this account.
  3. resent account verification email with required to change password on login

Any advice you can provide would be greatly appreciated..

11/18/2014 1:20:44 PM
Gravatar
Total Posts 18444

Re: Add Existing Content to new page

Have you created any global instances of html content? If there is no existing global content it may not work correctly.

Testing on the demo site it works for me, though at first I got an error page which turned out to be a db timeout error, but after creating a new global content instance it worked.

11/18/2014 4:25:04 PM
Gravatar
Total Posts 55

Re: Add Existing Content to new page

Joe, I have 3 HTML features flagged as global. I will try to remove and recreate the content to see if that fixes the issue and let you know.
11/18/2014 5:06:26 PM
Gravatar
Total Posts 18444

Re: Add Existing Content to new page

what version of mojoPortal?

11/18/2014 5:23:42 PM
Gravatar
Total Posts 55

Re: Add Existing Content to new page

Version 2.4.0.0

I was going to update to 2.4.0.3 but wanted to solve this first..

11/18/2014 5:45:04 PM
Gravatar
Total Posts 55

Re: Add Existing Content to new page

Make that 2.4.0.4.    

Grabbed the latest from CodePlex

11/18/2014 9:08:19 PM
Gravatar
Total Posts 55

Re: Add Existing Content to new page

Joe,

Upgraded using 2.4.0.4 deployment files from codeplex.

Brought site on-line however still having the same issue.

I have removed the flag from all the features using the global content and added 2 new HTML features and flagged them as global. Still getting the permission error. This is the only feature that I seem to have issues with as an administrator.

 

11/19/2014 11:11:02 AM
Gravatar
Total Posts 18444

Re: Add Existing Content to new page

In the page settings for the page where you are trying to add the content, what are the edit roles for the page, is it locked down to Admins only?

You say the user is in Admins role, what happens if you also add him to Content Administrators role? Does that work?

Can you replicate the problem on our demo site?

11/19/2014 5:20:03 PM
Gravatar
Total Posts 55

Re: Add Existing Content to new page

Joe,

Edit roles for the Page were the issue. All my pages have their edit roles limited to administrators only to help better enforce work flow since most of the Content Managers and Authors are inexperienced. I will replicate it on the demo site to see if that is the case there as well and let you know.. 

 

Thanks for the support..

 

Have a couple beers !! 

 

  

11/19/2014 6:18:05 PM
Gravatar
Total Posts 55

Re: Add Existing Content to new page

Joe, 

Quick update.  I was able to duplicate the issue on the demo site. It appears that if if the page security settings allow only administrators to edit the page content the access denied message is displayed when clicking the Existing Content link regardless of feature security settings. 

 

If you look at the demo site now I have added a new page called Global Feature. If you try to edit the page content and select the Existing Content link you will see it.. 

 

 

I realize this is a little spaghetti like, but here are the steps I took to create the issue.

  1. Add a new page
  2. From the Security tab click the "Roles that can edit this Page" option and make sure that Administrators, Content administrators is selected
  3. Save the page
  4. Add an html feature 
  5. From the feature security tab select the "Roles that can edit" and select Administrators only.
  6. Save the content
  7. Edit the page and remove the newly created content
  8. Edit settings for the page and select "Roles that can edit this page" and select Administrators Only.
  9. Save the page
  10. Navigate to a different page
  11. Navigate back to the test page and edit the page content
  12. Select the existing content and the message shows up.

Thanks for pointing it out. 

 

Joe

11/21/2014 7:38:05 AM
Gravatar
Total Posts 18444

Re: Add Existing Content to new page

Thanks for the clarification of steps to produce the problem. This will be fixed in the next release.

Thanks,

Joe

You must sign in to post in the forums. This thread is closed to new posts.