Error on publishing to Web

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
11/5/2014 1:06:23 PM
Gravatar
Total Posts 4

Error on publishing to Web

I have transferred the VS compiled version of the portal. I got the correct scripts notification on browsing to the site the first time. However when I browse after the setup ahs completed I get an error as follows

Theme 'default1art42-wallpaper' cannot be found in the application or global theme directories

I have aert42-wallpaper in the web directories but I cant find default1art42-wallpaper or where this is generated from.

 

Any Advise?

 

11/5/2014 1:24:31 PM
Gravatar
Total Posts 18444

Re: Error on publishing to Web

ok, so the skin isn't working or the new site is assigned a skin that does not exist.

The thing to do is login and go to Adminstration > Site settings, choose a skin from the list and click save.

11/5/2014 1:34:09 PM
Gravatar
Total Posts 4

Re: Error on publishing to Web

Thanks for the quick reply but maybe I wasn't quite clear in my explanation as I don't quite understand the reply.

When I try to browse to the default page the error screen is displayed with the message about the skin.

The art42-wallpaper skin exists, so I coped it and called the copy the name shown in the error screen. But it didn't make a difference

Is there a way to go to the administration without going to the default and signing in.

11/5/2014 1:45:14 PM
Gravatar
Total Posts 18444

Re: Error on publishing to Web

skins used by the site should exist at /Data/Sites/[SiteID]/skins where siteid is usually 1 for a new installation

the ones under /Data/skins is just a catalog of skins, when the site is created it should copy them to /Data/Sites/[SiteID]/skins

but something could have gone wrong so check and see.

also make sure you understand about working with the source code, and how to package a build, maybe compare the files from your package with the official release package to see if you are getting the right stuff.

actually your error makes me think you re-compiled the already compiled release package instead of the source code, that will break things

but you did not post much error detail, or stack trace

11/5/2014 1:54:25 PM
Gravatar
Total Posts 4

Re: Error on publishing to Web

The output from the error screen follows

Theme 'default1art42-wallpaper' cannot be found in the application or global theme directories. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: Theme 'default1art42-wallpaper' cannot be found in the application or global theme directories.

Source Error:
 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:
 

[HttpException (0x80004005): Theme 'default1art42-wallpaper' cannot be found in the application or global theme directories.] System.Web.Compilation.ThemeDirectoryCompiler.GetThemeBuildResultType(String themeName) +628 System.Web.Compilation.ThemeDirectoryCompiler.GetThemeBuildResultType(HttpContext context, String themeName) +145 System.Web.UI.Page.PerformPreInit() +118 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1844

 

I followed you instructions in the article about working with the source code. I am on VS2013 and I published to the file system, then uploaded to the site using FTP. Amended the web.config.

When I first browsed to the site I got the page that showed all the scripts running the database created and the page ended with no errors. I have checked the live site for the skins and as above the art42-wallper exists in the correct directory

 

I checked the permissions on the data directory and the NETWORK SERVICE has read write.

 

 

 

11/5/2014 2:20:13 PM
Gravatar
Total Posts 18444

Re: Error on publishing to Web

the error indicates that it is not using our virtualpathprovider for the theme, therefore it is looking in the wrong place for theme files

virtualpathprovider is known not to work in pre-compiled web sites which is what you get if you try to re-compile the already compiled files.

it also does not work in .NET 3.5 with medium trust hosting but the error should be different.

or there is something more information you have left out in telling me or you have modified the code or mixed it with some other code or some other web app that has its own global.asax.cs or something like that

11/5/2014 2:29:56 PM
Gravatar
Total Posts 4

Re: Error on publishing to Web

Yep sorry my error

 

I rechecked the compile options ofr the web and sure enough the precompile was ticked.

 

I have removed the option, rebuilt and republished

 

I have reset the live web, and it is now showing all the right things.

 

Sorry to have wasted your time.

 

 

11/5/2014 2:43:16 PM
Gravatar
Total Posts 18444

Re: Error on publishing to Web

the fact that you see an option for that just convinces me more that you are not using the source code, in mojoportal the Web project is a web application project not a web site project and there is no such option for web application projects in VS 2013 that I know of. only web site projects have that option as far as I know.

and when you open the pre-compiled mojoportal deployment package in VS it becomes a web site project because there is no .sln or .csproj files and no .cs files in the deployment package so VS just treats it like a web site project, but there is .sln and .csproj files in the source code, so you should not see an option like that if using the source code

so again I refer you the article understanding the difference between source code and pre-compiled deployment files

You must sign in to post in the forums. This thread is closed to new posts.