Form Wizard Pro checkbox/radio list items

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
8/5/2014 4:13:58 PM
Gravatar
Total Posts 30

Form Wizard Pro checkbox/radio list items

Development (http://vsi.visualsolutionsinc.com/custom-msp-package.aspx)--
What operating system: Win 2008 R2, IIS 7.5
What database platform: MS SQL 2008
What version of mojoPortal: 2.4.0.4
What version of .NET: v4.0.30319 Running in Full Trust

Live (WinHost.com) [http://www.visualsolutionsinc.com/custom-msp-package.aspx]--
What operating system: Win 2008, IIS 7.0 (i think)
What database platform: MS SQL 2008
What version of mojoPortal: 2.4.0.4
What version of .NET: v4.0.30319 Running in Partial Trust

I followed the instructions in this forum post (http://www.mojoportal.com/Forums/Thread.aspx?pageid=5&t=11054~-1) using both the theme.skin and css to format custom form wizard pro pages. My Theme.skin lines:
<asp:CheckBoxList  runat="server" SkinID="FormWizard" RepeatLayout="unorderedlist"/>
<asp:RadioButtonList  runat="server" SkinID="FormWizard" RepeatLayout="unorderedlist"/>

Steps to see the issue: got to the Custom MSP Package page and fill out the set of questions on the form, click Next to go to page 2 and see how the formatting is not matching up (live IE11 vs dev IE11, and IE11 live vs Firefox/Chrome live) it's using SPANs instead of UL/LI like dev and like Firefox/Chrome.

Some details: In Firefox, Chrome, and IE11 on the dev website listed above, I get the form correctly generated as UL and LI elements. However, today I moved it live and tested all pages. The custom page noted above generated UL and LI correctly in Firefox and Chrome, but in IE11 it's using span tags instead so the formatting is all off on the 2nd, 3rd, and 4th pages of the custom form.

I have:
-recycled the app pool on the live provider & also changed web.config and reuploaded to force a refresh
-reset the css guid in the admin menu
-cleared all cache in IE11 (though the old website was not mojo, so no caching of add-ons there)

I did notice on the system info page that the live provider is listed as "partial trust", even though I can write to all folders and should have full trust. I can't see how that would make a difference, especially with Firefox and Chrome working just fine providing UL and LI and not SPAN like IE11.

Thanks for any help!

8/5/2014 4:23:55 PM
Gravatar
Total Posts 18444

Re: Form Wizard Pro checkbox/radio list items

any IE 11 specific problems are most likely caused by not having all the windows updates installed on the server or something funky about the .NET framework installation, the missing updates add browser definition files to the machine and without them the server thinks IE 11 is a down level browser. The only solution to that kind of problem is to make sure all windows updates are installed and if that fails to solve it it may require re-installing the .NET framework. I suggest contact your host if it is not a server you control directly.

8/6/2014 11:32:51 AM
Gravatar
Total Posts 30

Re: Form Wizard Pro checkbox/radio list items

Yes, this is a hosting company, so I don't control the server. I'll contact them to have it reviewed. I tried a few more things today, none of which worked. I do have the host running full trust now using a web.config setting line, so at least everything I can control is matching from dev to live. But it's still using span's on IE11. Curious though is today I tested in windows virtuals I have, and IE 9 and IE 10 both look like they should. It is only for IE 11 this is happening.

8/6/2014 11:42:02 AM
Gravatar
Total Posts 18444

Re: Form Wizard Pro checkbox/radio list items

it makes sense, newer versions of browsers are not recognized until they get updated browser definition files in the .NET framework updates, unrecognized web browsers are treated as downlevel browsers. actually I'm surprised you are not having problems logging in with IE 11 because there are known issues with IE 11 login when the server does not have the updated browser definition files.

you may also want to check the web browser settings in IE 11 and make sure it is not using compatibility mode for the site, look under Tools > Compatibility settings

you may also want to try different skins and see if you get the same result, there could be a meta tag in the layout.master that forces IE compatibility mode for example and you don't want that

8/6/2014 12:09:16 PM
Gravatar
Total Posts 30

Re: Form Wizard Pro checkbox/radio list items

Actually, I don't use IE for any web browsing - just for compatibility/skin testing. I just tried to login and sure enough it fails like you said it would; I got "invalid viewstate" in the mojo logs. Hopefully I can get them to review and fix on their side.

I checked and no compatibility mode in my browser or in the layout.master file or in our domain's group policy for this site, and using the F12 IE tools showed it was in full edge/default mode (IE11 basically).

Thanks and I'll keep you posted.

8/6/2014 4:09:59 PM
Gravatar
Total Posts 30

Re: Form Wizard Pro checkbox/radio list items

The reply from the hosting company was that the Windows 2008 servers all are fully patched for .NET 4.0, current up to Windows Updates July 2014.

I am assuming at this point it is an issue with not having .NET 4.5 installed and it's associated Windows Updates. I've searched through the MojoPortal forums about IE11 (and the login issues you noted) and there's a few about this. Most say that even though running the MojoPortal .NET 4.0 version, IE 11/10 issues only got fixed when running on a server with .NET 4.5 installed. That might be the key difference - on my dev server I have .NET 4.5.1 and all updates installed.

If that's the case, then even though MojoPortal says it's .NET 4.0, it will only work for IE 11 if it's run with .NET 4.5 installed on the server.

Can you let me know if my assumptions are correct? I'm checking with hosting provider on .NET 4.5 options.

Thanks again!

8/6/2014 5:10:13 PM
Gravatar
Total Posts 18444

Re: Form Wizard Pro checkbox/radio list items

from previous threads about the IE 11 problems, basically I "think" that the windows updates do solve it in most cases even for  .NET 4, installing .NET 4.5 can fix it as well since that is an in place upgrade for .NET 4 but it seems that in some cases for some reason the windows updates don't fix it and the problem can also happen with .NET 4.5. In those stubborn cases it seems that re-installing the .NET framework can fix it, or using the aspnet_regbrowsers.exe tool may solve it. The problem with a stubborn case at a web host is whether they are willing to put in the time and effort to solve the problem for you. Some hosts will move your site to a different server if you ask them and you might get lucky with one that works since most machines do work after getting the updates. Getting the host to move you to .NET 4.5 hosting would be the best choice of all in my opinion.

8/7/2014 9:48:50 AM
Gravatar
Total Posts 30

Re: Form Wizard Pro checkbox/radio list items

For the hosting provider to move me to a server that has 4.5, it will be Server 2012 with IIS8. So now I'll need to create a test/virtual that matches that and test everything, in order to minimize downtime and deal with any issues that server and iis changes might throw into this mix. Do you know, from the forums or your experience, any gotchas I need to watch out for in setting up mojo on Server 2012 or IIS8? I know none of these are your issues or even Mojo issues, so again as always before thank you for your help.
 

8/7/2014 9:55:19 AM
Gravatar
Total Posts 18444

Re: Form Wizard Pro checkbox/radio list items

should not be a problem, .NET 4.5 should be the same no matter the OS, I develop locally on Windows 8.1 IIS 8 and deploy to Win 2008 IIS 7 with no problems or considerations, win 2012 with IIS 8 would be an even closer match vs my local machine but it really doesn't matter as much, only the .NET version needs to be the same in both environments.

8/8/2014 3:51:13 PM
Gravatar
Total Posts 30

Re: Form Wizard Pro checkbox/radio list items

Thanks again! That does make sense, but I wanted to ask just to make sure as I was sure you'd been through differing versions of server/IIS on all the work you do. I've got a Server 2012 with .NET 4.5 up and patched and am working on testing. Do you know of any other issues with IE 11 similar to these that is fixed by having a fully patched server fixing the issue. The login one and the form pro formatting / repeatlayout issue. That way I can test anything that might be similar and make sure it's all fully working on IE 11 on this dev server.

8/9/2014 8:35:19 AM
Gravatar
Total Posts 18444

Re: Form Wizard Pro checkbox/radio list items

I'm not aware of any other IE 11 issues and if such issues did exist I would expect them to be solved by the same updated browser definitions

You must sign in to post in the forums. This thread is closed to new posts.