Problem publishing using .NET 4.5 csproj files

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

Please do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.

This forum is for discussing mojoPortal development

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

You can monitor commits to the repository from this page. We also recommend developers to subscribe to email notifications in the developer forum as occasionally important things are announced.

Before posting questions here you might want to review the developer documentation.

Do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.
This thread is closed to new posts. You must sign in to post in the forums.
6/24/2014 12:14:23 PM
Gravatar
Total Posts 1188
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Problem publishing using .NET 4.5 csproj files

Hi Joe, in order to take advantage of the newest .NET 4.5 projects, I created a fresh clone of the repository, copied the sln file to a custom name, and merged in my existing custom projects.

However, when I try to deploy the project (to file system), I get this error:

Error    1    Copying file packages.config to obj\Release - MySql\Package\PackageTmp\packages.config failed. Could not find file 'packages.config'.        0    0    mojoPortal.Web

When I open mojoPortal.Web.csproj, near the bottom is an ItemGroup section referencing packages.config:

  <ItemGroup>
    <Content Include="packages.config" />
  </ItemGroup>

It doesn't look like packages.config is included in the repository. Do I need to do something to generate this file on my side?

Thanks,

Jamie

6/24/2014 1:37:33 PM
Gravatar
Total Posts 18444

Re: Problem publishing using .NET 4.5 csproj files

Hi Jamie,

That seems to be a file added by nuget that I did not notice. I've added it to the repository.

Sorry for the delayed response, apparently elastic email changed their configuration requirements without telling me and emails have been failing to get sent.

Thanks,

Joe

6/24/2014 1:42:57 PM
Gravatar
Total Posts 18444

Re: Problem publishing using .NET 4.5 csproj files

logged an email error for my last post so trying again just to see if the notification is fixed now

You must sign in to post in the forums. This thread is closed to new posts.