Sending Mail is not working in server side but working in local system

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

Please do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.

This forum is for discussing mojoPortal development

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

You can monitor commits to the repository from this page. We also recommend developers to subscribe to email notifications in the developer forum as occasionally important things are announced.

Before posting questions here you might want to review the developer documentation.

Do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.
This thread is closed to new posts. You must sign in to post in the forums.
6/16/2014 4:51:18 AM
Gravatar
Total Posts 5

Sending Mail is not working in server side but working in local system

Hi  joe

This is swetha,

iam not getting any mails from other users as iam admin of the page. And These below settings are working fine in local machine but on server side its not working

Here is my user.config setting

<add key="SMTPServer" value="smtp.gmail.com" />
    <add key="SMTPRequiresAuthentication" value="true" />
    <add key="SMTPPort" value="587" />
    <add key="SMTPUser" value="myID@gmail.com" />
    <add key="SMTPPassword" value="myPWD" />
<add key="SMTPUseSsl" value="true" />
     <add key="EnableSiteSettingsSmtpSettings" value="false" />
 <add key="SMTPTimeoutInMilliseconds" value="180000" />

=====================================================================================================

And Here is My Web.config settings

 <system.net>
    <mailSettings>
      <smtp from="myID@gmail.com">
        <network host="smtp.gmail.com" port="587" password="myPWD" userName="myID@gmail.com" />
      </smtp>
    </mailSettings>
  </system.net>

==================================================================================

In Contact form Settings

Email Address(es) To Receive Submissions:- myID@gmail.com

==================================================================================

In AdminSetting->Site Email From Address :-myID@gmail.com

========================================================================================================

In System log the following errros:-

2014-06-16 02:17:01,555 ERROR 49.204.226.50 - en-US - /contact - mojoPortal.Net.Email -

all retries failed sending email to myID@gmail.com from myID@gmail.com, message was: Admina<br />UserID@gmail.com<br /><br /><p>aaaa</p>
<br /><br />HTTP_USER_AGENT: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36<br />REMOTE_HOST: 49.204.226.50<br />REMOTE_ADDR: 49.204.226.50<br />LOCAL_ADDR: 23.91.123.136<br />


System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.5.1 Authentication Required. Learn more at
   at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
   at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, MailAddress from, Boolean allowUnicode)
   at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, Boolean allowUnicode, SmtpFailedRecipientException& exception)
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at mojoPortal.Net.Email.Send(SmtpSettings smtpSettings, MailMessage message)

 

 

Can Any Body Help me out with these problem.

Best Regards

Swetha

 

 

6/20/2014 8:00:51 PM
Gravatar
Total Posts 1188
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: Sending Mail is not working in server side but working in local system

Here's a troubleshooting document for Gmail SMTP:

https://support.google.com/mail/answer/78775?hl=en

It mentions that one thing you can try is to use port 25 with SSL:

If you tried configuring your SMTP server on port 465 (with SSL) and port 587 (with TLS), but are still having trouble sending mail, try configuring your SMTP to use port 25 (with SSL).

6/23/2014 3:34:04 AM
Gravatar
Total Posts 5

Re: Sending Mail is not working in server side but working in local system

Thanku Jamie,

I will try it .

6/23/2014 4:31:25 AM
Gravatar
Total Posts 5

Re: Sending Mail is not working in server side but working in local system

Hi,

 Thanku Jamie in advance,

Sorry, another couple of questions

Can you tell How To create Request a Quote page in aspx  with some inputs using textbox, checkbox, & button controls.

And How To store Those all values of Request a Quote page in dataBase .

Best Regards

Swetha

 

6/24/2014 12:07:47 PM
Gravatar
Total Posts 1188
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: Sending Mail is not working in server side but working in local system

You have two choices for a project like that. The first and far simplest solution would be to buy the mojoPortal add-on product Form Wizard Pro. With Form Wizard Pro, you can create a custom Request Quote form very easily. All of the email notifications, database storage, and database export options will be handled for you. You can play with a demo version of Form Wizard Pro on the mojoPortal demo site. We bought this product for our own site and I can highly recommend it.

The second choice is to develop a custom feature from scratch. If you want to do this, I suggest you go through Joe Audette's developer video series, where he walks through the steps required to create a guestbook application. That should be very similar to your Request Quote feature, so you'll be able to use the knowledge you've gained to develop your own feature.

Jamie

6/29/2014 4:16:27 AM
Gravatar
Total Posts 2

Re: Sending Mail is not working in server side but working in local system

Hi  Jamie ,

Sory for Late Reply.

As I tried your idea on sending Emails. Now Its working Fine 

Thankx for your the reply

Best Regards

Ali, Swetha

6/29/2014 5:17:54 AM
Gravatar
Total Posts 2

Re: Sending Mail is not working in server side but working in local system

Hi Jamie,

Hope all Fine there.

Can you tell me the , URL of repository which comes  after right clicking the in SVN CheckPoint.

For Creation of Request a Quote  Form.

Best Regards

ALi 

You must sign in to post in the forums. This thread is closed to new posts.