Newsletter Subscription - Confirming URL is too Long

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
3/14/2014 2:54:11 PM
Gravatar
Total Posts 29

Newsletter Subscription - Confirming URL is too Long

  • Windows Server 2008 R2 Standard
  • PostgreSQL 9.3
  • mojoPortal 2.3.9.9.
  • .NET 4.5
  • Newsletter module 2.2.4.6

We send a subscription confirmation e-mail to new subscribers. The e-mail message contains a link to confirm the subscription. The link in the e-mail is long, using an "s=" entry that is a GUID. This is too long for some users' e-mail clients.

Here is an example, which is (sadly) from an e-mail received by Microsoft's Outlook 2013--

http://www.oursite.com/eletter/Confirm.aspx?s=79b1bddc-ddc4-4f5f-bed8-7a8a01
d72803

Only the first line is used in the URL's click, and the mojoPortal page "Confirm.aspx" displays an error that it was not found.

  • Supposed authorities on-line all claim that Outlook should not do this. I have run Microsoft's supposed fix for this, both manual and automatic versions. But it is not fixed.
  • Suggestions I read on-line is to place the URL inside brackets: <http://UrlPath/file.aspx?s=123...>
    I cannot find any setting to have the module do this.
    I do not have source code for this module to make it do it.
  • Another suggestion is to have a service like TinyURL change the link to a shorter string, but this cannot be done with this module, either. This should not load a service like TinyURL just for one-time e-mail confirmations.
  • We have tried many times to teach users to simply paste the looped URL together, but few are able to do it. As a result, we have dozens of unconfirmed subscriptions in our lists.

Requests:

  1. Is there a setting somewhere in the module that can shorten this link? I have not been able to find one.
  2. Please modify the module to use a much shorter "s=" value. For example, it should be completely sufficient to use only the first 8 characters of the generated GUID, or at worst, the first 8 characters along with the final 5 characters. This would be more than unique enough for confirming a subscriber.

Thank-you.

3/17/2014 2:16:02 PM
Gravatar
Total Posts 18444

Re: Newsletter Subscription - Confirming URL is too Long

Hi,

I don't really consider this a bug in mojoPortal, seems like a bug in outlook and I don't really want to try using less than the full guid or shorten the url or use any 3rd party url shortener.

I have 2 suggestions to try, first is go ahead and add the brackets and see if that works. Just edit the file

/Data/MessageTemplates/en-US-NewsletterVerificationEmailMessage.config

change

{ConfirmationLink}

to

<{ConfirmationLink}>

let me know if that solves it and I'll make the same change.

The other suggestion is get the latest source code, deploy a new build and add this setting in user.config:

<add key="NewsletterUseHtmlEmailConfirmation" value="true" />

I just now implemented support for this setting and pushed it to the repository. By using an html email instead of plain text the length of the url should not be a problem. The default setting is false. The new html template is:

/Data/MessageTemplates/en-US-NewsletterVerificationHtmlEmailMessage.config

Hope that helps,

Joe

 

3/17/2014 2:59:07 PM
Gravatar
Total Posts 29

Re: Newsletter Subscription - Confirming URL is too Long

Joe,

Doing the item <{ConfirmationLink}> worked great in the e-mail sent for confirmation of the subscription. I'd do the change you mentioned already.

But...
I guess I wasn't clear enough, though. The problem wasn't the confirmation e-mail, but the newsletter itself. 
The #unsubscribe# key word in the e-mail message template. This is where the issue was noticed for us.

Is there a way to wrap <..> around in the #unsubscribe# item?

I will see if I can do an update to the latest version this weekend, if I can. But I don't think it covers this yet.

Thanks,

David

3/17/2014 3:03:18 PM
Gravatar
Total Posts 18444

Re: Newsletter Subscription - Confirming URL is too Long

The unsubscribe link in the html version of the newsletter should not be a problem since it is an html link. In the plain text version you could put the brackets around it yourself.

I will add the brackets in our plain text confirmation template.

3/17/2014 3:12:22 PM
Gravatar
Total Posts 29

Re: Newsletter Subscription - Confirming URL is too Long

"In the plain text version you could put the brackets around it yourself."

BINGO!

Yes, the confirmation issue was causing some people not to confirm their subscriptions. That's now fixed. 
Apparently the unsubscribe link on the newsletter itself is not a problem.

Thanks!

David

You must sign in to post in the forums. This thread is closed to new posts.