Can't Install MojoPortal 2.4

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
11/18/2013 3:06:03 PM
Gravatar
Total Posts 55

Can't Install MojoPortal 2.4

Hello, I tried to upgrade to MojoPortal 2.4 from 2.3.9.7 via FileZilla.

I accidentally uploaded everything at once. I later followed all the instructions from the Installation FAQ and such, but when I do the setup via Setup/Default.aspx, the system still says 2.3.9.7.

How can I ensure that my site is updated with 2.4.0.0?

 

 

11/18/2013 3:20:46 PM
Gravatar
Total Posts 18444

Re: Can't Install MojoPortal 2.4

does not sound like all the files got uploaded. Please upload again starting with the /Setup folder.

11/18/2013 3:34:48 PM
Gravatar
Total Posts 55

Re: Can't Install MojoPortal 2.4

I tried to do it again, but with Setup first and it still didn't work. 

I will try once more and let you know.

11/18/2013 8:42:36 PM
Gravatar
Total Posts 55

Re: Can't Install MojoPortal 2.4

It's still 2.3.9.7 even though I did everything correctly. I even backed up web.config and uploaded it again after doing the Setup -> ClientScript -> Data procedure.

I don't know what I did wrong. 

11/18/2013 9:39:55 PM
Gravatar
Total Posts 1992

Re: Can't Install MojoPortal 2.4

Hi,

Which db platform are you using? If it is MySQL, be sure to upload the Setup folder from the MySQL datalayer package to your site as well placing the DLLs in the bin directory.

You shouldn't use the same web.config from version to version. You should use the new web.config which comes with the release and copy your changes to it.

HTH,
Joe D.

11/19/2013 9:34:42 PM
Gravatar
Total Posts 55

Re: Can't Install MojoPortal 2.4

I am not using a db. I just upload files through FileZilla. I've done that for all the updates so far and been successful..

 

11/19/2013 11:05:18 PM
Gravatar
Total Posts 1992

Re: Can't Install MojoPortal 2.4

Well, mojoPortal must have a DB or it can't work. Which file do you download from the mojoPortal Codeplex site? What is it named?

Thanks,
Joe D.

11/20/2013 10:06:40 AM
Gravatar
Total Posts 18444

Re: Can't Install MojoPortal 2.4

Hi Tony,

It should say on the setup page which db platform is being used. either mssql, mysql, sqlce, pgsql, sqlite or firebird. As Joe D said mojoPortal does use a database, no way it can work without one.

From what you are saying it sounds like possibly you are not uploading to the site where you think you are uploading. 

also I keep unsubscribing you from forum email because email keeps bouncing back from your address.

Hope that helps,

Joe

11/21/2013 9:49:59 AM
Gravatar
Total Posts 55

Re: Can't Install MojoPortal 2.4

It's MySQL. 

11/21/2013 10:34:00 AM
Gravatar
Total Posts 18444

Re: Can't Install MojoPortal 2.4

so you need to download our mysql data layer package and upload the /Setup folder and dlls from that package go in the /bin folder.

11/24/2013 7:26:47 PM
Gravatar
Total Posts 55

Re: Can't Install MojoPortal 2.4

It's actually MSSQL on Net 4.0. Unfortunately, nothing is working. I followed instructions on MojoPortal, but the site is still registered as 2.3.9.7.

You must sign in to post in the forums. This thread is closed to new posts.