can no longer login to Portal after configuring LDAP

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
10/3/2013 11:57:05 AM
Gravatar
Total Posts 3

can no longer login to Portal after configuring LDAP

I thought i did it all right, i can create users with no admin rights, but my Admin@admin.com user wont log in, my other admin user will not log in i need to know how to get back in to the admin settings and change things back.   Is there a back door?  tell me there is something better than a reinstall.

10/3/2013 12:14:19 PM
Gravatar
Total Posts 18439

Re: can no longer login to Portal after configuring LDAP

Right admin@admin.com is not going to be authenticated by your ldap server, that is why step 3 in the instructions is important.

To go forward I would go into the database mp_Users table

Since you have a row with admin@admin.com that is wired up with admin roles and you also have a new user that you created by logging in with ldap, copy the loginname and email address from the new ldap user row to the old admin@admin.com user row and then delete the row for the new user so there is no duplicate. Now login as the new user and you should be administrator.

Hope that helps,

Joe

10/3/2013 12:28:49 PM
Gravatar
Total Posts 3

Re: can no longer login to Portal after configuring LDAP

Thanks for the reply, i assume that the table is in the SQL database?   I have never logged in with a LDAP user, it wont take any LDAP user names.   My AD names / email addresses i tried will not work or log me in i registered a new user that worked but that was as far as i got.   No LDAP user logged in.  

10/3/2013 12:45:49 PM
Gravatar
Total Posts 1204
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: can no longer login to Portal after configuring LDAP

If LDAP isn't working at all, your only remedy right now is to go into the database directly and turn off LDAP altogether.

update mp_sites set UseLdapAuth = 0;

When you're ready to test again, I'd suggest enabling database authentication with LDAP fallback, and make sure at least one admin user has a known mojoPortal password so you can get back in as needed using database rather than LDAP authentication.

 

10/3/2013 12:49:18 PM
Gravatar
Total Posts 18439

Re: can no longer login to Portal after configuring LDAP

If you registered a new user after configuring it for AD/LDAP, then I assumed it registered a user from AD/LDAP. 

I suggest go into the database in the mp_Sites table and change the UseLdap field to 0 or false. After updating the data recycle the app pool or touch Web.config to clear the cache.

Then, next time if you want to keep trying ldap, check the box in site settings for "Use Database Authentication With LDAP Fallback"

That way the existing database users will keep working so you can get back in as admin if ldap is not working.

10/3/2013 12:50:54 PM
Gravatar
Total Posts 18439

Re: can no longer login to Portal after configuring LDAP

Thanks Jamie! Must have been still typing my answer while you posted.

10/3/2013 12:52:09 PM
Gravatar
Total Posts 3

Re: can no longer login to Portal after configuring LDAP

Thank you, so now that is my new issue, i can not get the SQL Management studio to load on the machine.  

10/3/2013 1:00:33 PM
Gravatar
Total Posts 18439

Re: can no longer login to Portal after configuring LDAP

Sorry but these forums are not for support of sql management tools, there are lots of good places on the web for help with that but it is outside the scope of these forums.

You must sign in to post in the forums. This thread is closed to new posts.