2.3.9.7 upgrade issue

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
5/25/2013 7:07:21 PM
Gravatar
Total Posts 503
feet planted firmly on the ground

2.3.9.7 upgrade issue

I've just upgraded a site on Arvixe to 2.3.9.7 but got this feedback:

Welcome to mojoPortal Setup

Setup is disabled but running setup anyway because current user is an administrator.
Probing system...
File system permissions ok.
MSSQL database connection ok.
database permissions are sufficient to alter schema.
database initial schema already exists.
database core schema is up to date.
1 site(s) found.
Configuring feature Html Content - 00:00:00.1470000
Configuring feature Site Statistics - 00:00:00.1690000
Configuring feature Child Page Site Map - 00:00:00.1740000
Configuring feature Newsletter Sign Up Form - 00:00:00.1750000
Configuring feature Recent Content - 00:00:00.1850000
An Error Occurred:String or binary data would be truncated. The statement has been terminated.
Source:.Net SqlClient Data Provider
Stack Trace at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction) at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady) at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource`1 completion, Int32 timeout, Task& task, Boolean asyncWrite) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at mojoPortal.Data.SqlHelper.ExecuteNonQuery(String connectionString, CommandType commandType, String commandText, Int32 commandTimeout, SqlParameter[] commandParameters) at mojoPortal.Data.SqlParameterHelper.ExecuteNonQuery() at mojoPortal.Data.DBModuleDefinition.UpdateModuleDefinitionSetting(Guid featureGuid, Int32 moduleDefId, String resourceFile, String groupName, String settingName, String settingValue, String controlType, String regexValidationExpression, String controlSrc, String helpKey, Int32 sortOrder) at mojoPortal.Business.ModuleDefinition.UpdateModuleDefinitionSetting(Guid featureGuid, Int32 moduleDefId, String resourceFile, String groupName, String settingName, String settingValue, String controlType, String regexValidationExpression, String controlSrc, String helpKey, Int32 sortOrder) at mojoPortal.Web.UI.Pages.SetupHome.SetupFeature(ContentFeature feature) at mojoPortal.Web.UI.Pages.SetupHome.SetupFeatures(String applicationName) at mojoPortal.Web.UI.Pages.SetupHome.RunSetup() at mojoPortal.Web.UI.Pages.SetupHome.Page_Load(Object sender, EventArgs e) at System.Web.UI.Control.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
 

The site now claims to be 2.3.9.7 but clearly the upgrade did not complete. What now?

Thanks

5/26/2013 3:15:37 AM
Gravatar
Total Posts 503
feet planted firmly on the ground

Re: 2.3.9.7 upgrade issue

and now although much of the site is working, I am getting this fatality on a blog page:

2013-05-26 03:12:01,903 ERROR 37.152.211.57 - en-GB - /blog - mojoPortal.Web.Global -  Referrer(http://www.breconfans.org.uk/stuff) useragent Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0; BOIE9;ENUS)
System.IndexOutOfRangeException: ShowAuthorName
   at System.Data.ProviderBase.FieldNameLookup.GetOrdinal(String fieldName)
   at System.Data.SqlClient.SqlDataReader.GetOrdinal(String name)
   at System.Data.SqlClient.SqlDataReader.get_Item(String name)
   at mojoPortal.Business.Blog.GetPageDataSet(Int32 moduleId, DateTime beginDate, Int32 pageNumber, Int32 pageSize, Int32& totalPages)
   at mojoPortal.Web.BlogUI.PostList.BindBlogs()
   at mojoPortal.Web.BlogUI.PostList.Page_Load(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
etc

I think I will attempt a complete upgrade again.

5/26/2013 4:25:51 AM
Gravatar
Total Posts 503
feet planted firmly on the ground

Re: 2.3.9.7 upgrade issue

Have done the upgrade again - copying the 2.3.9.7 files into the faulty installation, set the machine key and folder permissions, then run /setup/default.aspx... same problem again.

Help would be appreciated. Stupidly, because these upgrades usually go smoothly, I do not have a complete copy of both folders plus database from just before this upgrade attempt, so cannot simply revert to previous.

5/26/2013 10:05:21 AM
Gravatar
Total Posts 18444

Re: 2.3.9.7 upgrade issue

The error seems to indicate that either blog upgrade script(s) are missing or for some reason did not execute. First I would check what version it says for the blog under Administration > System Information

It should be version 2.6.1.2, if it is not then scripts are missing. If the version looks correct then it somehow failed to run 1 or more of them. To troubleshoot that I would review the upgrade scripts from newest to oldest and manually run any script fragment that updates procedures to contain the field is is complaining about.

Look under /Setup/applications/blog/SchemaUpgradeScripts/mssql for the scripts. From a quick review it looks like the select procedures in script 2.6.0.8 are the relevant ones that somehow did not get updated in your installation

Hope that helps,

Joe

5/26/2013 4:04:09 PM
Gravatar
Total Posts 503
feet planted firmly on the ground

Re: 2.3.9.7 upgrade issue

Hi Joe

Running those blog scripts in manually has fixed the blog - thanks. But running setup/default.aspx still throws the original error (above), suggesting a problem around the Recent Content feature or whatever comes immediately after that. Presumably this prevented any other scripts running, so it would be good to identify the cause.

I have remembered that this site had its database in SQLCE originally, then migrated to SQL Server. Could that be the cause?

PS I've just upgraded another site (without a hitch!) and found that this is the sequence:

Configuring feature Recent Content - 00:00:06.1030000
Configuring feature Sign In Module - 00:00:06.1710000
Configuring feature Site Search - 00:00:06.1720000
Configuring feature Bing Map - 00:00:06.2100000

so the error in my upgrade is presumably something to do with the Recent Content module or perhaps Sign In though that seems unlikely.

 

5/27/2013 11:04:44 AM
Gravatar
Total Posts 18444

Re: 2.3.9.7 upgrade issue

The other error is happening while trying to migrate blog comments to the new comment system. Unfortunately I made the name column only 50 chars in the new one while the old blog one allowed 100 and apparently you have 1 or more rows where the data is bigger than 50 chars so its causing this error.

The only immediate solution is to run a query on the mp_BlogComments table to shorten any values longer than 50 chars in the name field. Then the setup page should be able to migrate the data.

5/28/2013 4:01:44 PM
Gravatar
Total Posts 503
feet planted firmly on the ground

Re: 2.3.9.7 upgrade issue

Hi Joe

The contents of mp_BlogComments have migrated successfully into mp_Comments, and the values in the [name] field were all <50 chars.

Any tips on how to diagnose what is going wrong?

thanks

5/29/2013 10:50:01 AM
Gravatar
Total Posts 18444

Re: 2.3.9.7 upgrade issue

I would look at mp_ModuleDefinitionSettings table and mp_ModuleSettings table and make sure the SettingValue field in both tables is of type nvarchar(max), if not then change it to that and try visiting the setup page again.

5/29/2013 1:37:12 PM
Gravatar
Total Posts 503
feet planted firmly on the ground

Re: 2.3.9.7 upgrade issue

Hi Joe

OK sorted - I scripted out all the tables from the bad database and compared to structures from a good one, and found a thousand diffs, then fixed the ones that seemed important.

I think the one that made the big difference and allowed the upgrade to run was mp_ModuleDefinitionSettings.SettingValue which was nvarchar(255).

Thanks for your help - have a couple of pints of Murphy's!

 

 

5/29/2013 1:58:23 PM
Gravatar
Total Posts 18444

Re: 2.3.9.7 upgrade issue

Thanks for the beers!

Cheers!

Joe

You must sign in to post in the forums. This thread is closed to new posts.