error with postgreSQL when runing mojoportal

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
4/8/2013 4:40:21 AM
Gravatar
Total Posts 9

error with postgreSQL when runing mojoportal

when i wan to run the mojo portal for postgreSQL version, a problem occures :

 

Probing system...
File system permissions ok.
pgsql database connection ok.
database permissions are sufficient to alter schema.
database initial schema already exists.
database core schema is up to date.
1 site(s) found.
Configuring feature Html Content - 00:00:00.1757700
Configuring feature Site Statistics - 00:00:00.7274925
Configuring feature Child Page Site Map - 00:00:00.7587405
Configuring feature Newsletter Sign Up Form - 00:00:00.7606935
Configuring feature Recent Content - 00:00:00.8017065
An Error Occurred:ERROR: 22001: value too long for type character varying(255)
Source:Npgsql

Stack Trace à Npgsql.NpgsqlState.d__a.MoveNext() à Npgsql.ForwardsOnlyDataReader.GetNextResponseObject() à Npgsql.ForwardsOnlyDataReader.GetNextRowDescription() à Npgsql.ForwardsOnlyDataReader.NextResult() à Npgsql.ForwardsOnlyDataReader..ctor(IEnumerable`1 dataEnumeration, CommandBehavior behavior, NpgsqlCommand command, NotificationThreadBlock threadBlock, Boolean synchOnReadError) à Npgsql.NpgsqlCommand.GetReader(CommandBehavior cb) à Npgsql.NpgsqlCommand.ExecuteNonQuery() à mojoPortal.Data.NpgsqlHelper.ExecuteNonQuery(String connectionString, CommandType commandType, String commandText, NpgsqlParameter[] commandParameters) à mojoPortal.Data.DBModuleDefinition.CreateSetting(Int32 moduleDefID, String groupName, String settingName, String settingValue, String controlType, String regexValidationExpression, Guid featureGuid, String resourceFile, String controlSrc, Int32 sortOrder, String helpKey) à mojoPortal.Data.DBModuleDefinition.UpdateModuleDefinitionSetting(Guid featureGuid, Int32 moduleDefId, String resourceFile, String groupName, String settingName, String settingValue, String controlType, String regexValidationExpression, String controlSrc, String helpKey, Int32 sortOrder) à mojoPortal.Business.ModuleDefinition.UpdateModuleDefinitionSetting(Guid featureGuid, Int32 moduleDefId, String resourceFile, String groupName, String settingName, String settingValue, String controlType, String regexValidationExpression, String controlSrc, String helpKey, Int32 sortOrder) à mojoPortal.Web.UI.Pages.SetupHome.SetupFeature(ContentFeature feature) à mojoPortal.Web.UI.Pages.SetupHome.SetupFeatures(String applicationName) à mojoPortal.Web.UI.Pages.SetupHome.RunSetup() à mojoPortal.Web.UI.Pages.SetupHome.Page_Load(Object sender, EventArgs e) à System.Web.UI.Control.OnLoad(EventArgs e) à System.Web.UI.Control.LoadRecursive() à System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint).

 

any suggestions please!!
 

4/8/2013 12:55:33 PM
Gravatar
Total Posts 18444

Re: error with postgreSQL when runing mojoportal

I will have to investigate and make the field larger in the database to make a correct fix.

For now a workaround to get past the error:

Edit the file

/Setup/applications/mojoportal-core/FeatureDefinitions/99999_RecentContentModule.config

​remove the default value from the first featureSetting in that file

save the file then visit setup page again

Hope that helps,

Joe

4/8/2013 1:28:37 PM
Gravatar
Total Posts 18444

Re: error with postgreSQL when runing mojoportal

Ok, instead of the workaround just run this sql command on your db:

ALTER TABLE mp_moduledefinitionsettings ALTER COLUMN settingvalue TYPE text;

Then refresh the setup page

4/9/2013 4:20:48 AM
Gravatar
Total Posts 9

Re: error with postgreSQL when runing mojoportal

Hi joe,

i just wanted to tell you that i've created my database with no tables in it, and assigned it to a user with a password so the sql request will not work, can you give me more explanations about the database contents.

thank you Mr joe.

4/9/2013 6:23:38 AM
Gravatar
Total Posts 18444

Re: error with postgreSQL when runing mojoportal

I have patched the mojoportal 2.3.9.6 pgsql packages to fix this problem. If you download it again and install from scratch it should work without errors.

4/9/2013 9:55:03 AM
Gravatar
Total Posts 9

Re: error with postgreSQL when runing mojoportal

Hi joe,

thank you for your precious help, the step for loading the files successfully done but when i click the link to the home page it gives me this error:

The WebResource.axd handler must be registered in the configuration to process this request.

<!-- Web.Config Configuration File -->

<configuration>
   <system.web>
       <httpHandlers>
           <add path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader" validate="True" />
       </httpHandlers>
   </system.web>
</configuration>

cant you help me with this !

thank you Mr joe

4/9/2013 10:28:08 AM
Gravatar
Total Posts 9

Re: error with postgreSQL when runing mojoportal

Hi Mr joe,

i just wanted to thank you for your efforts , the site has finally started !! 

the only thing is that i see just the site without any css style .

thank you Mr joe.

4/9/2013 12:25:56 PM
Gravatar
Total Posts 18444

Re: error with postgreSQL when runing mojoportal

try going to Administration > site settings and choose a new skin and click save

If the problem persists after that then view the source of the page and click the link for csshandler.ashx?...

if you get an error instead of css then you need to talk to your host because .ashx extension for asp.net is not correctly registered.

Same thing if you get errors about WebResource.axd it means something is not configured correctly for asp.net on the server.

4/10/2013 5:31:04 AM
Gravatar
Total Posts 9

Re: error with postgreSQL when runing mojoportal

Hi Mr joe,

mojoportal works fine !! thank you for your instructions.

2 things are strange !!

     -) First thing, he took time to load the home page

     -) Second thing, I've added the "Mypage" for webparts features but it doesn't shows on the site.

final thing if you can tell me how to run the site in the integrated mode !

thank you Mr joe,

You must sign in to post in the forums. This thread is closed to new posts.