This is a forum to suggest new features for mojoPortal.
Not sure whether to file this under bugs or feature requests...
The current naming convention within Newsletters is very confusing since the parent and child objects are both named "Newsletter". It adds to the difficulty of training clients in using this already fairly complex feature.
Please could we rename the Child objects "Editions" - this would then follow the same convention as paper newsletters, newspapers and magazines.
I think I get what you're saying. I can update the labels so that instances of a newsletter are consistently labeled as "Edition" rather than "Letter" or "Newsletter"
Brilliant - thanks!