SSL error message

This is the place to report bugs and get support. When posting in this forum, please always provide as much detail as possible.

Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum, do not report it as a bug.

This is the place to report bugs and get support

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.
Please do not report problems with a custom build or custom code in this forum. If you are producing your own build from the source code and have problems or questions, ask in the developer forum.
This thread is closed to new posts. You must sign in to post in the forums.
10/24/2012 9:15:39 PM
Gravatar
Total Posts 215

SSL error message

After upgrading from 2.3.9.0 to 2.3.9.3 I'm now getting a strange SSL error on my only site that's using SSL (and has been for a couple months).

Here's the error which is inside of the sign-in module:
https://www.milwaukeecurlingclub.com/members-area.aspx

This message in red wasn't there before the upgrade and SSL was working OK. I have the page settings "force ssl" checked and I'm using a skin that has all links in SSL. No matter what I try the red warning message won't go away. Thoughts? Something must have changed since the last upgrade.

10/25/2012 6:44:05 AM
Gravatar
Total Posts 18439

Re: SSL error message

Hi Eric,

I noticed that bug shortly after the release and have already fixed it. Its only supposed to show that message when SSL is available but is not used on the page containing the login module.

However you can disable that message immediately by adding this to user.config:

<add key="ShowWarningWhenSslIsAvailableButNotUsedWithLoginModule" value="false"/>

Best,

Joe

10/25/2012 10:09:59 AM
Gravatar
Total Posts 215

Re: SSL error message

Darn, didn't work. I touched the web.config.

Here are my setting in user.config related to SSL. Site #4 is the one with SSL on it. I tried changing some of the other true/flase options below but they had no effect.

<add key="Site4-SSLIsAvailable" value="true" />
<add key="EnableSSLInChildSites" value="false" />
<add key="SSLIsAvailable" value="false" />
<add key="SSLIsRequiredByWebServer" value="false" />
<add key="ResolveFullUrlsForMenuItemProtocolDifferences" value="true" />
<add key="ShowWarningWhenSslIsAvailableButNotUsedWithLoginModule" value="false"/>

10/25/2012 10:51:51 AM
Gravatar
Total Posts 18439

Re: SSL error message

Hi Eric,

That should have worked. There are a couple other ways to solve it though.

Hide it by css .nosslwarning { display:none; }

or from theme.skin set the Visible property to false.

<portal:InsecurePageWarning runat="server" Visible="false" />

Best,

Joe

10/25/2012 11:07:12 AM
Gravatar
Total Posts 215

Re: SSL error message

I should have thought to do that (css hide). Thanks Joe (for putting classes on everything!!).

In case someone else has the problem until the next build the actual class name is called "sslwarning"

.sslwarning { display:none; }

You must sign in to post in the forums. This thread is closed to new posts.